Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S8 smart lock - trusted location issue

(Topic created on: 02/05/17 16:00)
sabina_bl
Apprentice
Options
Other Smartphones

Hi,

 

the smart lock - trusted location option is not working as it should do.

i've set up my home address as a trusted location, however, my S8 device is unlocked everywhere.

just realised this while i was in the office, that i can access my device withouth using the PIN or the fingerprint.

i've oppend the maps and the location that it shows up is correct. 2miles away from my home address.

 

the only workaround that i found was to turn off the trusted location, and now the device is asking for the PIN.

 

this is a serious security issue. the trusted location option is not that trusted :smiling-face:

 

any idea?

 

thanks,

sabina

116 REPLIES 116
Nuija
Apprentice
Options
Other Smartphones

I did post earlier that clearing Google Maps - Storage Cache solves this problem.

Sometimes phone may still require a  restart after the smart lock has been operating flawlessly for days.  

After this restart you may have to clear that Google Maps - Storage Cache again. 

 

Here is a handy way to do this:

1) Open Google Maps and let it locate your position you have marked as a Trusted location 

2) Open Multitasking Menu (usually the left side of the Home button)

3) Hold your finger on little Google Maps Icon on left side of the Maps window until it opens Google Maps app Information icon on the right and, when you touch that it opens panel where you can Open Storage and clear its cache. In older Androids it opens this panel directly when holding finger on Maps icon, in newer via little info ( i ) icon. 

 

0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

Cleared the cache before, probably when you posted before but going to give it a shot again, got the update last week so maybe the combination will fix it plus did a factory reset the other day, so cleared cache, restarted, cleared cache. I know doing the multiple spots seemed to help but it would be nice to not have a list of coords for one place.

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

Well, I did test adding multiple trusted  locations around my house using the placed using the Placed Pin option.

When I walked away from my home Trusted Locations System went bananas and ended up thinking that I'm home all the time even half a kilometer from my home.

I had to remove all those extra places and use the one and only location which Maps always finds first when I'm at home. In your case I would use only a couple of most commonly found places where the system locates you at home. Otherwise  the system may end up practically disabling the pin code protection. 

0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

No luck, had to unlock every time I used at home after going through those steps, gave up just doing the device proximity to keep it unlocked now, still sucks because it messes up the stuff I have set for geofencing

JohnnyJames
Apprentice
Options
Other Smartphones

SOLUTION

None of these solutions worked for me BUT what did is setting my home address in the Samsung galaxy account.

It has been 2 days and smartlock still works.

I Hope it works for you too.

Google settings has nothing to so with smart lock.

Find "Galaxy Apps" amongst the rest of your apps. If you cant see it, search for it I am looking now for where to add your home adress but cant find where i went.

Ill come back with proper instructions when i find it again.

Just know that the solution is to add your home to actual samsung account. Ill be back when i remember how i did it. Im pretty sure it was in "galaxy apps" good luck and if someone else finds it, please post for others as this was a very annoyong issue

0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

Nothing has worked for me yet either, gonna try what you said, in galaxy apps click my apps, then email at the top then add address to Samsung account?

0 Likes
Reply
JohnnyJames
Apprentice
Options
Other Smartphones

Sorry. I cant find where i did it but there was a google maps thing like when you add it normally but it was in my samsung acc somewhere. It was only 2 days ago. If you figure it out let me know as its. Bothering me now that i cant remember

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones
Both Samsung and Google are really good at hiding those settings, every system update tries to bury that setting to even deeper and under a newly named category.

It is usually in "Settings" (cogwheel icon) and under some subcategory of category "Lock Screen and Security", in subcategory which name can also slighty change depending system version and Samsung's latest idea of usability 😃
0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

Hi Johnny, when you added your address to yout galaxy account service, that service gives that location to Google Map services. Trusted places means trusted places, not just home. 

 

I had my home address also registered but it did not help at all, because where I live the Google Map service sometimes locates me outside my house  when I am inside my home. 

 

I actually had to add two most common locations where Google Maps finds me most often when I am at home and now the system works most of the time. ; )

0 Likes
Reply
JohnnyJames
Apprentice
Options
Other Smartphones

Ok got it.

Go into settings then

Cloud/apps

Select your samsung acc

(It will say your email underneath

Then click places and add your home.

Worked for me and is the only thing that did.

GOOD LUCK let me know how it goes

Nuija
Apprentice
Options
Other Smartphones

Still doesn't work with me, since phone sees me in different location where I actually am. 

Can you check closely time to time where your phone is located in  Google Maps. If the location dot stays in the same place all the time then it works, otherwise not. 

Whether the address is called home or work is irrelevant. 

Today my phone thinks persistently that I am not in those two locations what I have marked around my home to be recognised as my home, and the lock is not working again.

The saddest thing here is that there is no option to define the actual range around that located position that would always be considered safe. That would solve all these issues...

0 Likes
Reply
JohnnyJames
Apprentice
Options
Other Smartphones

Have you tried holding the location button and ticking those box's for max accuracy?

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

Yes, I have it on high accuracy all the time, but I live in an old building with castle thick walls and in ground floor. There is no way satellite positioning works here. Google Map services uses wifi signal and net node points to "guess" the phone location, and depending on the star positions in the universe, decides that my phone jumps by itself back and forth in the courtyard, usually in some corners opposite the corner where my home is ; )

0 Likes
Reply
JohnnyJames
Apprentice
Options
Other Smartphones

My smart lock is still working.

I think this is the solution for most people besides the guy with the accuracy problem. 

Recap: go into settings/cloud&apps/samsung acc/places then add your home.

My smart lock is open at home since i did this. Before it would not stay ipen at home 

 

0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

No luck with that for me either, still unlocking everytime I'm home unless I use trusted devices, I've taken google maps and location services off the battery saving *****, and turned off the battery saver, still get drift

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones
Did you check time to time your exact location. If the dot jumps around even a little (in my case 20m around the court yard), I know for sure that it will not help what ever one registeres as home. As said, I did register my home address and it did not help at all, because phone thinks that I am outside ; )
Check three days in a row at different times closely in Google Maps (zoom in as much as you are able) where phone locates you, and if the dot jumps around tens of meters and this registering your home address to Samsung eliminates the fact that position changes radically, then I believe you. 😃
0 Likes
Reply
JohnnyJames
Apprentice
Options
Other Smartphones

Ok mine stuffed up again after 3 days but i got ut working again by deleting my home amd trustes places on all accounts then addes my home again, didnt work but then I added the trusted place as my homes co-ordinates and ut is working again. Hope this is helping someone and i hope this lasts. Wtf is wronf with this, samsung needs to fux this bug in an update asap.

 

0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

They do but problem is this is a 2 month old post now and they haven't done anything, and it got marked as solved, luckily my upgrade date is coming soon and it will not he another samsung

BRAMAGE
First Poster
Options
Other Smartphones

AGREED -  Although I am not who sure to pin this issue on, it sucks. The S8 always seems to be a complete hasle to unlock. Add Bixby (and the Bixby button) , and I absolutly hate this device.  Cant say I ever felt that way about any phone.

 

I even found a "how-to (s8)" video on-line, and the guy fumbles with the phone through 4 key presses and a couple of swipes before he gets it unlocked.  The S8 is my last Samsung phone.  I had an S9 reserved, but decided I don't want another year hating my phone.  Will probabaly try the LG..  (Although I hear it will have a dedicated assisant button - That I am sure will suck.)  I may even get a cheapo for a year until they get fingerprint on the glass.  When I broke my S7, I had a $40 phone off Amazon, and it worked fine.  I have been tempted to put my SIM back in that and wait out a phone I might actually love  😕

 

Contract with Amazon, drop an Alexa Button, I am all in.   

0 Likes
Reply
OhSamsong
New Member
Options
Other Smartphones

Updated my samsung account location and now the location smartlock has worked for the 1st time ever.

0 Likes
Reply
gboybama
First Poster
Options
Other Smartphones

@OhSamsong wrote:

Updated my samsung account location and now the location smartlock has worked for the 1st time ever.


They must have finally done something.  My smartlock has not forgotten it's supposed to be unlocked in a while now.  It's a major improvement.

0 Likes
Reply