Open search

S8 smart lock - trusted location issue




the smart lock - trusted location option is not working as it should do.

i've set up my home address as a trusted location, however, my S8 device is unlocked everywhere.

just realised this while i was in the office, that i can access my device withouth using the PIN or the fingerprint.

i've oppend the maps and the location that it shows up is correct. 2miles away from my home address.


the only workaround that i found was to turn off the trusted location, and now the device is asking for the PIN.


this is a serious security issue. the trusted location option is not that trusted :smiling-face:


any idea?




116 REPLIES 116

No Samsung members app, not sure where to get not seeing it in play store or galaxy apps, I have the Samsung+ app but not seeing any support feature with error reporting just social, community and support numbers


Are you located within the UK, @PariahComplex? If anyone else is still experiencing this problem, please follow the steps provided by @AntS so we can look into this for you.


Within the message content include your Community username (eg: LiamH) so I can search for your error log. If you can let us know when you've sent this, I or another one of the moderators will be able to chase this up for you guys. 



Hi, I did try downloading the app but it tells that it is not compatible with my device, which is a bit older than the newest models. 


This Trusted locations problem seems to be affecting many other Android phone brands, too. 


It has 2 problems to be solved:

1) inaccuracy of the Google Maps location Service time to time

2) time out of the Service that checks whether the device is in the Trusted Places environment.


I have added 3 different locations around my home (10 meters apart, when I did notice that  the phone keeps  finding me in those locations randomly. 


If I restart my phone every morning then the Trusted places works usually all day, no matter whether I am at work in between. Very rarely If System doesn't work, then I clear Google Maps cache, restart the phone, log in to see the UI, wait for the carrier signal, open the Google Maps to verify the phone finds in right location. After this procedure it works again (but still requires phone Restart every morning). 


My assumption is that some specific Google service process that checks the location for Trusted places times out after four hours of phone inactivity and this Service is only activated again during the phone restart. With good debugging tools it shouldn't be too difficult to find out which Process this is. 


Nope I'm not UK this was the top thread that came up when I was looking a while back, but he's right I'm pretty sure, seems when the phone goes off it kills GPS, mine seems to be immediate as ill let the screen close at 15 secs and have to unlock right after, I took maps and location services out of the battery optimization and no luck, was hoping it would stop doze from killing them


@AntS wrote:

Hi all.


I've taken off the 'Accepted Solution' marker on this one. Do any of you guys experiencing this issue have access to the Samsung Members app to send our software team an error report and log files for them to look into it? (Within 15 minutes of it happening, open Samsung Members app > select Support > Send Feedback > Error Reports > Application > tick Send System Log Data, and attach a description of the problem.)

Hi Ant,


Smart Lock, which worked fine during the Oreo beta testing and previously on Nougat, is now temperamental.

It seems to be an issue with Trusted Locations. After a while, the phone seems to 'forget' that you're in the trusted location (even if you haven't moved at all) and reverts back to asking for biometrics.

A workaround that seems to work for now is uninstalling all the updates to the Google app, and using the factory version of this app instead. Having done that, Trusted Locations SEEMS to be working fine.


So I suspect there is an issue with compatibility/settings in the latest versions of the Google app. Until this is resolved, I will not be updating my Google app and will continue to use the factory installed version, because Smart Lock is too important to me.


Please investigate compatibility issues with the Google app and Trusted Locations.


I have sent a report with system log files. 



Weird solution (courtesy of someone on a Google Pixel forum - err, thanks, Samsung....) but working so far:


I uninstalled all updates to the Google app, turned off automatic updates in the store, removed all my Smart Lock settings including my Screen lock settings and restarted the phone.

After the above, I added my fingerprint and PIN and set up Smart Lock once again. It's working now with no issue since this afternoon
Seems like the Google app itself is the culprit, so all the people posting 'fixes' to do with the Maps app seem to have been pointing fingers at the wrong Google software!
If you have tried everything else, try the above and see if that works for you, too.
I have also reported this through the Samsung Members app and attached system logs. Very much hoping that Samsung can take a look at the Google app and see if there are any compatibility issues preventing Smart Lock from operating as it should. We shouldn't have to rely on using older versions of software to allow system functions to work! 
Worth mentioning though, that other Android phones are experiencing this issue. I've seen it on a number of different threads. Seems to be an Oreo issue and/or some problems with the Google app itself. HOWEVER, I will also say that other phone manufacturers are actually responding to their users and taking steps to isolate and explore the issue, which is more than I can say for Samsung (I started a thread about thie issue on here and gave a very detailed account of the different steps I took and I got ZERO response/help from Samsung. When I sent the same message to them on Twitter, their stock response was, 'Maybe take it into a store...?'
Not great. 

My problem with all these suggestions is they're location based. Why does my phone keep locking when constantly paired to my smart watch that's listed as a trusted smart lock connection? There's no excuse for that. If connected, then lock = off. It's pretty freaking easy code y'all. 


Sorry, but I was responding to the original message which stated that there was a Trusted Location issue, which is what I was experiencing too. 


I was just trying to be helpful by providing a workaround which - so far - has been working for me. 


However, I agree. It's really shoddy that Smart Lock - which is a big selling point of Android - is having so many issues post-Oreo update, and I hope Samsung look at the sheer volume of people posting about this issue. It's obvious that something somewhere has gone wrong. 


It might be worth trying to uninstall the updates to the Google app on your phone though, since Smart Lock is a Google service. It's possible that the issues you're facing with your Bluetooth device could also be due to a compatibility issue with Oreo and a newer version of the Google app. You have nothing to lose by uninstalling the updates and trying to update your Smart Lock options using the factory installed version of Google. If it doesn't solved your issue you can just update the app again. 


Thanks going to try that, and I've tried that "take it into a store", about my wifi calling and mms not working, the Samsung " expert" there said "yeah mine does that once in a while as well" and handed my phone back


'reboot into recovery' details please? Will I have to set up my phone again if I do this?

Top Liked Authors