Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S8 smart lock - trusted location issue

(Topic created on: 24/03/18 11:54)
sabina_bl
Apprentice
Options
Other Smartphones

Hi,

 

the smart lock - trusted location option is not working as it should do.

i've set up my home address as a trusted location, however, my S8 device is unlocked everywhere.

just realised this while i was in the office, that i can access my device withouth using the PIN or the fingerprint.

i've oppend the maps and the location that it shows up is correct. 2miles away from my home address.

 

the only workaround that i found was to turn off the trusted location, and now the device is asking for the PIN.

 

this is a serious security issue. the trusted location option is not that trusted :smiling-face:

 

any idea?

 

thanks,

sabina

116 REPLIES 116
Nuija
Apprentice
Options
Other Smartphones
Well, in that case there is not much to be done, of course this drifting may depend on where your mobile phone picks the signal that it uses to calculate your location. In my case these spots near by were quite regular. In your case placing your location far away tells that there are only limited amount of available signal towers and probably too many users online at the same time, pushing you to the next available signal tower further away. If you have better GPS signal, using that might help. You can also check are these random spots far away regular and add all of them. In my case activating wifi drifted my location accurately back to home, since I have allowed Google to use wifi for locating my phone. Without wifi, I was located to the opposite building regularily.
0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

Have it set to high accuracy, I know I basically have no cell tower near me, think the closest is about 5 miles, but the location and smart lock worked perfectly until an update a little while back, did a factory reset last night so crossing my fingers

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones
I am pretty sure that just deleting only Google Maps Cache should solve the problem, since that is the service that tells your phone is. I assume you do not have a land line and wifi on that available. That would lock your location tightly.
0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

No landline but have wifi on, had a lot more problems anyways so needed the reset

0 Likes
Reply
Gypsy
New Member
Options
Other Smartphones
Me too. The only fix I have found is to delete "home" altogether. Then, if you are at home, go to "Add Trusted Location" and use the GPS location. The annoying part about this is that when you delete "home" it deletes "home" across all Google applications. Definitely a bug.
0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

It also seems that the Google Maps light blue circle or the dotted line which is shown when one defines the trusted location has nothing to do with the actual "what is considered as a trusted area" concept. This morning my phone refused to understand that it was home again and I did test adding 10 close by spots (moving the found pin and picking points outside around the house) around my house an suddenly phone started understand that it, indeed is in a trusted environment. ; )

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

I have now investigated this issue further. In my phone I must sometimes restart the phone in order get trusted locations work again. In another newer edition of same phone model this is not needed. I did check which position Google Maps most often finds when I am at home and defined that as a safe location (that is in the yard outside of the house). There might still be some operating system bugs that may require occasional phone restarting.

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

I did post earlier that clearing Google Maps - Storage Cache solves this problem.

Sometimes phone may still require a  restart after the smart lock has been operating flawlessly for days.  

After this restart you may have to clear that Google Maps - Storage Cache again. 

 

Here is a handy way to do this:

1) Open Google Maps and let it locate your position you have marked as a Trusted location 

2) Open Multitasking Menu (usually the left side of the Home button)

3) Hold your finger on little Google Maps Icon on left side of the Maps window until it opens Google Maps app Information icon on the right and, when you touch that it opens panel where you can Open Storage and clear its cache. In older Androids it opens this panel directly when holding finger on Maps icon, in newer via little info ( i ) icon. 

 

0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

Cleared the cache before, probably when you posted before but going to give it a shot again, got the update last week so maybe the combination will fix it plus did a factory reset the other day, so cleared cache, restarted, cleared cache. I know doing the multiple spots seemed to help but it would be nice to not have a list of coords for one place.

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

Well, I did test adding multiple trusted  locations around my house using the placed using the Placed Pin option.

When I walked away from my home Trusted Locations System went bananas and ended up thinking that I'm home all the time even half a kilometer from my home.

I had to remove all those extra places and use the one and only location which Maps always finds first when I'm at home. In your case I would use only a couple of most commonly found places where the system locates you at home. Otherwise  the system may end up practically disabling the pin code protection. 

0 Likes
Reply