Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S8 smart lock - trusted location issue

(Topic created on: 17/03/18 12:04)
sabina_bl
Apprentice
Options
Other Smartphones

Hi,

 

the smart lock - trusted location option is not working as it should do.

i've set up my home address as a trusted location, however, my S8 device is unlocked everywhere.

just realised this while i was in the office, that i can access my device withouth using the PIN or the fingerprint.

i've oppend the maps and the location that it shows up is correct. 2miles away from my home address.

 

the only workaround that i found was to turn off the trusted location, and now the device is asking for the PIN.

 

this is a serious security issue. the trusted location option is not that trusted :smiling-face:

 

any idea?

 

thanks,

sabina

116 REPLIES 116
HulloSon
First Poster
Options
Other Smartphones

I added several trusted locations within my home, trying to bracket the place. Let's see how that works.

0 Likes
Reply
sjbrad61
First Poster
Options
Other Smartphones

I have an S7. After spending a lot of time following the procedure you referenced, which I found elsewhere first, this SIMPLE method is what finally worked for me.  I stumbled onto it:

SMART LOCK FIX SAMSUNG GOOGLE
For Home setting not working:

In Settings, Go to Location. Toggle it OFF then ON! It Resets it! ☺

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

Found an easy solution:

1) Open Settings - Apps 

2) Find Maps and select Storage and in there press CLEAR CACHE

No need to clearn Samsung cache or reset anything else. It seems that Maps app cache gets corrupted time to time when phone updates its apps constantly. Sometimes Maps can fix it when I just open Google Maps and zoom into my current location. After the latest major system update this didn't help at all, but clearing just Google Maps cache did help immediately. This fix may work with some other brand phones, too. 

Nuija
Apprentice
Options
Other Smartphones
Hi, try my solution which I just posted. I think that might help...
0 Likes
Reply
Mellie13
First Poster
Options
Other Smartphones
Thank you x
0 Likes
Reply
Ken13
First Poster
Options
Other Smartphones

I have the same issue with my s8. Very annoying and I've cleared cache and did everything necessary then it started working then after 3 hours again same thing. They don't really care about us 😞

0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

I went into settings>device maintenance>battery>battery usage, press three dots in top right, optimize battery usage, choose all apps, then went down to location services and unselected it, seems to be working now, I know after update when screen went off GPS would go off and location would drift so took it off of the battery optimization so hopefully it runs while screen off, not sure but seems to have been working since I did that yesterday, to verify that's on my s8

0 Likes
Reply
Nuija
Apprentice
Options
Other Smartphones

Check where Google Maps locates you when Smart lock isn't working. In my case it sometimes locates me just outside the range to the opposite building. Adding these a-bit-off locations nearby helped me. It's a pity that one can't define the range what is considered safe distance. 

0 Likes
Reply
PariahComplex
Explorer
Options
Other Smartphones

Unfortunately mine seems to randomly drift, once it said I was about 5 miles SW in a lake, trying to set up a location based IFTTT last night it had me about 2 miles NW

0 Likes
Reply
AjanJack
Apprentice
Options
Other Smartphones

Just a thought. If you are not using GPS to locate your position then your location is being triangulated by cell phone towers which are not accurate at all.  Check to see if your Settubgs-Connections-High accuracy is turned on or not.

0 Likes
Reply