What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

S7 black screen and unresponsive

(Topic created on: 16-02-2020 01:16 PM)
First Poster

Hey everyone,

Having issues with my Galaxy S7 32gb, 2.5 years old, whereby the screen is completely black and unresponsive, and I’m unable to switch it back on, or enter recovery mode. No previous issues with this, and no drop or water damage.

**Background to the issue
Unplugged my phone from an overnight charge and was browsing on Chrome, when the phone hung and wouldn’t respond with any buttons. No external stimuli to cause this, aside maybe heat - have been travelling around Asia for 3.5 months whereas I usually reside in the UK. No hotter on this particular session than normal though - was in an A/C room.

After a little while of no response the screen eventually went black, as if switched off, and wouldn’t respond.

**Steps I’ve tried
1. Holding the power button - no response
2. Vol down + power - no response
3. Vol up + home, then + power - no response
4. Plug in phone to charge - no lights and no response

All in all it seemed like the phone was dead and unresponsive, despite having almost 100% battery when I was using it. However, I left the phone for the day to see if anything changed when I’d let the battery run down. After a few hours I tried again and steps 1-3 still didn’t work, however plugging my phone in caused the Samsung Galaxy S7 splash screen to show. Next what happened:

1. Blue screen ‘Installing system update’
2. Followed by a blue screen, with a yellow warning sign and white android logo, with text ‘No command’
3. Recovery screen then showed
4. Performed a clear cache partition
5. Phone reboots and gets to my unlock screen, but shows 0% battery and dies again despite being plugged in
6. Reboots to unlock screen again and then freezes
7. Phone now back to its original problem - black screen, unresponsive buttons, unresponsive to a charger

**Where I’m at
I’m now back to having an unresponsive black screen phone. It feels like if I leave the battery to drain again I might get another shot at getting to the recovery menu when I plug it into charge.

If I do, is there anything else I can try? A factory reset perhaps? Or does anyone have any similar experience or ideas as to why the phone is behaving this way? Could it just be getting too old and dying?

I need to try everything I can to self-troubleshoot and fix myself as I’m still travelling for another 3 months and can’t realistically send the phone anywhere for repair.

Thanks in advance!

Samsung Members Star ★★

whereas I usually reside in the UK. "


In the UK there is Samsung Experience Stores or Samsung Service Centres who can usually help in house so there is no need normally to send the phone away.


The manufacturer warranty has elapsed as this is 2 years but they may still be able to help as long as the phone shows no signs of accidental damage and the water indicators have not been tripped @Jamicar 


I wish you all the best with this situation. 





Daily Driver > Samsung Galaxy s²⁴ Ultra 512Gb ~ Titanium Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help. " This is the way. "

First Poster

I have tried all the same things and having the same issue, i really like this phone (S7 Edge SM-935F)and would like to fix it.


For me the screen froze on uninstalling Elisa Elamus application, then phone turned off and hang on android logo. Next time it just would not turn on and now i have a dead phone.


What could it be?

First Poster

My phone died in a similar way, I was uninstalling Montorsport Manager 3 cause my phone had been complaining of low space. I was uninstalling several apps and this one was one of the big ones (370MB). It was uninstalling and suddenly it went black. I think at some point I saw the clock appearing so I just pressed the Home button to see how it was and it went black. After that I googled and tried those Vol.Down+Power and other combinations but nothing.

The LED was blinking as if it still detected there were new messages but I couldn't do anything. Eventually the light died and the phone is not charging.


Any other ideas?

First Poster

Did you try again after battery drain? Did you get anywhere this time?

I'm curious as I'm in a similar situation right now. My S7 is dead, unresponsive... I've let it drain for several hours and eventually it's come up with the charging logo when connected via USB. I've let it charge to 60% or so and tried to turn it on ... and after several attempts and a few power+volume down (held for 5-7 seconds), I got it to start and the phone appeared to be working - so I took that time to backup all I needed onto an SD card - which has failed a couple of times with a freeze, but power+volume down managed to reboot it 3-4 times until it no longer started, locked up on Samsung logo and then died again...
Today, it shows the charging logo (lightning bolt on a battery icon), but does NOT indicate any charging (doesn't show any % of charge as it did last night)... So I'm afraid it's stuck again 😞

Along the way, I've managed to get to some reboot option screens, safe mode, cache clearing ... but they didn't help... So I was planning to try a factory reset as a last resort (now that I've backed up all that's important, I can do it, however painful it'll be to get everything installed again - but at least, or so I'm hoping, the phone will work again and stop rebooting / freezing / dying).

First Poster

I'm in the exact same situation. First, I got a message about running out of internal memory so I've uninstalled a couple of applications and ever since then, the phone kept on freezing up at random times (sometimes running fine for many hours, other times freezing before it even asked me for the pin at startup)... Eventually it's died completely and became unresponsive to any attempt of power-up, safe mode, diagnostics with various combinations of power + volume + home buttons...

I've let it sit on my desk for several hours and when I plugged in a charger, it actually showed it's charging - got to 60% before I tried actually powering it up ... and after several attempts and reboots (holding down power + volume down for 7s) I managed to get the phone started and operational ... at least for a little while - enough to get a backup of important data to an SD card ... then it died again, completely, no response to anything...

Today it shows the lightning icon on a battery outline but I don't think it's actually charging. Even to get this far, I had to plug it in to my PC and hold down power + volume up and maybe home (I don't recall which actually got me the lightning screen as I've tried many combinations)...

I'll let it sit like that for a while to see if it's actually charging or just stuck frozen on that screen. If it's frozen then there's hope it'll drain the battery down to a point it'll start charging eventually (or so I hope) as at least the screen is using up some power, speeding up the battery discharging process.

I'll let you all know if I got it working again, perhaps a factory reset if I get to that screen again.

First Poster

hi ya,has any one resolved this problem i have same issue myself,and am going to try and put a new battery see if that works.please someone help.   Rod