Support

Open search

S Health MyFitnessPal Sync issue

Highlighted
First Poster

Has anyone had problems getting SHealth and MFP to sync calories correctly? The exercise syncing seems fine but the calorie syncing seems to only partially work. Specifically I record food in MFP and it only ever part syncs to S health so the calorie totals are not the same, and wierdly it seems to only affect the "dinner" element which only syncs some of the food items (breakfast/lunch/snacks seems to work OK).

 

I am on a new S8+ if it matters.

Any ideas?

5 REPLIES 5
Highlighted
Pathfinder

Hi, @JimboM3

Have you ensured that your software is completely up to date? 

Have you been in contact with My Fitness Pal regarding this? 

Highlighted

I found the same issue after a hard reset of my phone (S7 edge) and re-installed every app form my Samsung Account backup


I did the factory reset OTA update from Android 6 to Android 7 -After this update, the battery was draining 50% after the update (all Samsung products have an awful battery, all of them).

 

Anyway, unfortunately, there is nothing useful al over the web. I found a post-answer from MFP team:

 

"Thanks for posting and sorry for any trouble. We are aware of the problem with the steps not syncing from S-health, and are currently investigating. We hope to have a fix in place as soon as possible. Please accept our sincerest apologies for any inconvenience this may have caused. We appreciate your patience and understanding."

 

So to this point, I found my self on trying to get a solution but still without any positive results. Maybe for you works


What I've tried:

 

1) Clearing cache memory for both apps, close them and restarting the device, but everything seems to be with no change. NO SUCCESS

 

2) Uninstalling and installing MFP again, manually but directly from the Play Store (instead from a backup)
Gave again all the permission for read-write between apps, but NO SUCCESS

 

3) Activating/de-activating permissions in both apps.

 

Please let me know if you get lucky with this issue.

 

 

 

Highlighted

I am also having the same issue and i found a fix. all you need to do is open your MFP app>open drawer(leftside Bar)>Apps & Devices>Samsung Health App>Connect. That should do the trick. It works for me.

 

Hope it works on your end.

 

Cheers mate!

Highlighted

Have the same issue it would appear. From what I've noticed if you log 1 of any item it works OK but if you log more (eg 3 egg portions) it only syncs 1 eggs worth of protein so reduces the protein  count and calorie data in samsung health. I'd guess from this the problem lies in mfp data transfer arithmetic rather than the actual data transfer setup between the different apps..... 

Highlighted
Observer

I am experiencing something similar.  I use a GearFit and MFP.  When I do a workout DVD I set my watch to "other workout" and it tracks the calories and ports them to MFP.  When I run I set it to run, it ports to MFP.  When I run on the treadmill I set it to treadmill, it posts to MFP.  Those all work great.

 

But when I set my gearfit to WALK, it WILL NOT port the calories burned to MFP.   Why won't it post the walking workouts to MFP?

 

I've reinstalled both apps.  I've connected and disconnected and connected.  I've done all those things.  So annoying!  Anyone know why this is happening and how to fix it?

Top Liked Authors