Open search

GPS still not working properly


started a new topic because someone marked the last one as solved and there's still people posting there with the same ongoing issue for months now and I know once it's mark as solved wether it actualy is or not it gets ignored, several of us cannot use the device location smart lock, can clear dalvik, clear maps cache, restart phone, everything and it works for maybe an hour or two then back to unlocking while home in the marked location, this doesn't only effect the smart lock as I have a few apps (IFTTT, Life360, Vudu) that use geofencing and its rendering them useless, particularly Life360 as it's on my young daughters phone so we know when she leaves home and enters school safely but nope, not anymore, it seems when the screen goes off and the battery saving rest mode garbage kicks in it's killing gps because I can open maps and see my location has drifted a few miles from where i actualy am and then it will snap back, and even while open I can see my location drifitng around my yard, basically moving out of home location and back, yes I have the high accuracy on and wi-fi scanning and bluetooth scanning, this is getting really old and annoying that this has been going on for months and no fix and it just started doing this after an update, I thought the oreo update may have fixed the issue but no luck, here's the old thread since i don't feel like going through and copy pasting the stuff that has been tried


Adding this post of mine from other thread that shows what I've tried:



Yes, cleared cache, cleared data, cleared dalvik, erased smart locations, put them back, used home, used coords for home, set home location then 8 more around the house overlapping home location (N, NE, E, SE, S, SW, W, NW), force stopped maps, used GPS keeper which worked for a week, set the home location in samsung account, turned off battery optimization for location services and maps and basically anything I could find that said location, turned off app power monitor, I've done a factory reset, and I'm sure someone will ask so yes my high accuracy mode is on with the wifi bluetooth scanning


Edit: I've also tried other 3rd party apps to fix gps, and registered my location with 911 services just in case that location was needed, highly doubt that though, not sure about other providers but for the sprint calling plus you have to, which coincidentally the wifi calling rarely works either, nor does SMS/mms work properly"


As said before (in the other forum), only clearing Google Maps cache helps, no other cache or trick. Also I have noticed that when I come to my home from work it almost works 100% all the time, opening the phone correctly, not requiring the PIN code .


But in the mornings when I have stayed in home all night it might ask me again the PIN code. In that case I must restart the phone and open it first time with the PIN code and zoom in Google Maps so close that I see for sure that Google Maps really wants me at that Trusted location close to the one of the three pins which I have placed around my home as trusted places. Annoying, but works!

This issue is caused by the fact that the phone really doesn't understand It's exact location most of the time. Also another problem is that Trusted place range from the Selected trusted pin can't be defined large enough. After checking closely the locations of the phone finds me when the Smart Lock doesn't work I found three different locations, all of them on my yard. Smart lock feature is so picky that even some ten meters away from the defined location causes it to fail. 


So, I agree that  this issue is not solved for good yet. But unless Google really does something about it, it won't be solved. Defining a clear trusted area visible range on on the map would be a good start!

New Member

Bump since this group appears old and issue still occurs

Top Liked Authors