Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

galaxy S8 - USB headset not working in phone app

(Topic created on: 01/09/19 17:08)
holcus
First Poster
Options
Other Smartphones

galaxy S8

Jabra EVOLVE 20 SE MS

 

I am unable to use my USB headset to make phonecalls, all phone sounds go via build-in speaker. I don't even get the phone app sounds of dialing numbers etc. Audio playback works fine in browser or music apps.

I get a similiar issue with messanger app where I can hear in app sounds but the actual voice call is done over build-in audio speakers / mic.

 

What I tried so far:

- disable / enable USB audio routing

- Default USB configuration: MIDI

 

I suspect this has something to do with microphone not being detected properly since voice recorder app also uses built-in mic. Mic in headset itself works fine when connected to linux and Windows PC.

How can I fix this?

6 REPLIES 6
ChrisM
Moderator
Moderator
Options
Other Smartphones

Hi @holcus 

 

Are you able to try another set of headphones in the phone to see if you can replicate the issue?

holcus
First Poster
Options
Other Smartphones

I only have a Samson Go MIC to test. It's a USB microphone with 3.5 headphone out.

Unfortunately it does not play sound at all from my s8, not even for browser audio.

Interestingly, my micro-USB galaxy S7 does play from browser with the above setup (still no sound on phonecalls)

I'll try to test on some other headsets at work.

Michminn
First Poster
Options
Other Smartphones

Were you able to find a resolution to this? I'm having the same issue with my plantronics headset when trying to place calls.

0 Likes
m971668
First Poster
Options
Other Smartphones

Same issue.. Samsung S8 with DeX Station in DeX mode, logi USB headset with microphone.

0 Likes
Jammie
First Poster
Options
Other Smartphones

same problem  here. I'm using jabra evolve2 40 usb C headphone. It doesn't work on phone app and whatsapp, duo calls on Samsung S9+ and galaxy M31.

It works fine on music apps. And calling also works fine withPC  apps like teams ,Skype etc. Does anyone has a fix for this??

 

0 Likes
7moodDxB
Apprentice
Options
Other Smartphones

Same problem here, I have the S8+ and recently been using S20's earphones that came with that device, I think it's the USB audio's problem because I tried a few headphones and earphones and still had the same problem, I hope Samsung fixes it, or maybe they did on newer models

0 Likes