Support

Open search

Cell Standby/Android System/Google Play Services battery drain for Oreo on S7

Highlighted
Explorer

Hi, 

 

I really like my S7 Edge. However as a direct result of installing the Oreo update I have significant battery drain. The drain is attributable to cell standby which sometimes reaches over 50% of battery use. It definitely did not do this on Nougat, ever. 

 

I have not added any apps to cause this problem and would really like a suggestion about what to do. I can't believe Safe Mode will have any effect as this has happened as a result of the upgrade, not rogue apps. I am not keen to do a factory reset either as I can't see the benefit. I have cleared the cache, removed some apps, restarted etc, turned off any battery hungry options in settings but to no avail.

 

If anybody could help me I would be very grateful. I believe it is a bug in Oreo or Samsung's altered version of Oreo but cannot prove either. I can't think what to do apart from find out how to downgrade back to Nougat, which I don't want to do.

 

Many thanks.

 

739 REPLIES 739
Highlighted

I talked to a samsung "tech" online and she told me to dial *#0228#, then hit the quick start button and now cell standby is normal again.. i dont now if that was the issue or its just a big coincidence, but now its at 1% again!

Screenshot_20180623-175931_Settings.jpg

 

Highlighted

you have wifi on thats why
test on data only

Highlighted

I've signed up for a Samsung account to let Samsung know that our two S7 flats have the same standby drain issue following Oreo installation noted here by others, and that we would be likely to look to other manufacturers when renewal comes up this fall unless Samsung demonstrates a commitment to keep older phones working.

 

Also, our son misses your sponsorship of Chelsea FC - your logo looked much better than Yokohama!

Highlighted
First Poster

same prblm here as well

galaxy s7 after oreo update

screen on time less than 2 hrs

Highlighted

Hey guys, I have same problem with my s7 g930FD after update battery drain fast

Highlighted

I had the same battery drain issue after S7 edge Oreo update until I disabled 4G call (VoLTE for other regions) in Settings -> Connections -> Mobile networks -> 4G call. No need to restrict background usage. Also disable Wi-Fi Calling. Hope this works for you as well and Samsung fixes the issue fast.

Highlighted

@LongDenis wrote:

I had the same battery drain issue after S7 edge Oreo update until I disabled 4G call (VoLTE for other regions) in Settings -> Connections -> Mobile networks -> 4G call. No need to restrict background usage. Also disable Wi-Fi Calling. Hope this works for you as well and Samsung fixes the issue fast.


It's a good thing that it works for you, here I don't have VoLTE nor WiFi calling but I still have the issue so maybe I'm missing something or simply I cannot disable what creates the problem

Highlighted

 


@Carolll wrote:

@LongDenis wrote:

I had the same battery drain issue after S7 edge Oreo update until I disabled 4G call (VoLTE for other regions) in Settings -> Connections -> Mobile networks -> 4G call. No need to restrict background usage. Also disable Wi-Fi Calling. Hope this works for you as well and Samsung fixes the issue fast.


It's a good thing that it works for you, here I don't have VoLTE nor WiFi calling but I still have the issue so maybe I'm missing something or simply I cannot disable what creates the problem


Same for me, I can't diable these settings (can't be found on some specific firmwares), and it's not the 1st time I hear about VoLTE.

 

I read it can be disabled using some app by killing process which names contain IMS. It seems weird I can't disable VoLTE but it seems I do have these process running in the background (IMS logger, service and settings).

 

I'll try disabling these tomorrow.

 

 


 

Highlighted

@Sylva1n wrote:

 

Same for me, I can't diable these settings (can't be found on some specific firmwares), and it's not the 1st time I hear about VoLTE.

 

I read it can be disabled using some app by killing process which names contain IMS. It seems weird I can't disable VoLTE but it seems I do have these process running in the background (IMS logger, service and settings).

 

I'll try disabling these tomorrow.

 

 


 


Yep Samsung keeps alive tons of tasks even when they are useless. I never disabled IMS services because I didn't feel sure about it so I can't tell. On airplane mode I have no overheating nor battery drain but I don't know if IMS would work only on mobile data

Highlighted

Where do I find the wi-fi calling option to disable?

Top Liked Authors