Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Block unknown/private numbers doesn't work.

(Topic created on: 30-06-2021 04:33 PM)
ChrisKots
Apprentice
Options
Other Smartphones
Hello. As the title implies,  this setting doesn't work.  I'm still receiving spam calls from unknown numbers even after enabling the setting.  Thanks.
0 Likes
5 REPLIES 5
LiquidSnake
Big Cheese
Options
Other Smartphones
Try restarting the phone. If that doesn't work, clear the phone system cache 😀
0 Likes
AndrewL
Moderator
Moderator
Options
Other Smartphones

@ChrisKots: Have you also enabled Caller ID and Spam Protection? If not, open the Phone app > Tap the 3 dots in the top right > Settings > Caller ID and Spam Protection > On > Block Spam and Scam Calls > On. Let me know if this help. 

0 Likes
ChrisKots
Apprentice
Options
Other Smartphones
Hi Andrew. I don't have the Caller ID and Spam Protection under Settings. Thanks. Screenshot_20210701-143120_Call settings.jpg
0 Likes
ChrisKots
Apprentice
Options
Other Smartphones
I have cleared system cache and restarted. It might have worked as I haven't any spam calls during the last 2 days. Thanks.
LiquidSnake
Big Cheese
Options
Other Smartphones
Nice! If this tip helped, can you please click the three dots on my comment and select the 'accept solution' option? Thanks! 😊
0 Likes