Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Not getting voicemail notifications

(Topic created on: 03-11-2021 04:43 PM)
91184 Views
MagTulsa
First Poster
Options

I see that many of you are having the problem of not getting rid of your voicemail notifications.  I have the opposite problem.  Somehow my voicemail notifications are turned off, and I can't get them back on.  When I go into the settings/notifications and select phone, the "Show notifications" button is highlighted in blue, and I can't turn it on.  I am grateful for any advice you can give.

1 Solution


Accepted Solutions
Solution
PVanderv
Apprentice
Options

Solved it!  😄  Works for my Galaxy S20.

1 Open the Settings app (Gear on the home screen).
2 Tap Apps.
3 Tap the "sort by" icon -- It's the faint little icon with the little down arrow and the three horizontal lines on the right side of the screen just above the list of apps, opposite "Your apps" on the left
4 Tap "Show system apps", tap "OK".

Clear Call settings Cache:
5 Tap "Call settings".
6 Tap Storage.
7 Tap "Clear cache" on the bottom of the screen.
8 Tap the back key twice

Clear Voicemail Cache same way

View solution in context

0 Likes
18 REPLIES 18
xSteveuk
Mastermind
Options
Hi
Try below

Setup voicemail on Galaxy S21

Open the “Phone” app.
Tap the 3 dots on the top right
Tap “Settings“.
Tap “Voicemail“.
Tap “Voicemail Settings“
Take note of the green number below “Voicemail number“.
Go back to the dialer and enter the number (including the *)
Press the green phone button.
0 Likes
LiquidSnake
Big Cheese
Options
Try wiping the cache partition on the phone and that should resolve the issue. To do this, just search 'how to wipe cache partition S21' and you should find what you are looking for 🙂. Hope this helps! 😎
0 Likes
Blake101
Apprentice
Options

I am having the same problem. I have the verizon sim card with Stright Talk. I get my voicemail but I don't get my notification letting me know that I have one. I actually have to call my voicemail to see if anyone has left me one. When I go into the settings/notifications and select phone, the "Show notifications" button is highlighted in blue. (it's already turned on and you can't turn it off.) MagTulsa, did you ever find a solution?  Does anyone have any advice they could give me? 

Kelly Logue
First Poster
Options

I have the exact same issue as you.  I have an unlocked S22 using the verizon sim card they sent me.  Can't turn notifications on or off. 

0 Likes
Blake101
Apprentice
Options

Hey Kelly, my phone is a dual sim card phone, my verizon account with straight talk doesn't support the dual sim card feature. Everything works but my voice mail notifications. What I had to do was download a third party voice mail app. The one I use is YouMail. Have been very happy with it, works as it should.

0 Likes
jojobott
First Poster
Options

I have the exact same problem.  Did you ever get it answered.

 

0 Likes
BillS21
Student
Options

I had been having the same problem with my new S21 Ultra. To fix it, I cleared the app data, force stopped the app, restarted the phone, restarted the app, and then allowed the permissions requested when the app started. 

0 Likes
AD781
First Poster
Options

Did you get this resolved? I have exact same issue

0 Likes
Bamejer
First Poster
Options

My wife and I are have been having the same issue for a while.  What is the fix?

0 Likes