Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

NO SIGNAL S21 Ultra

(Topic created on: 16-08-2022 08:41 PM)
4470 Views
DannyStarbs
First Poster
Options
Is anyone else having issues with no signal? My wife and I have the exact same phone on the exact same contract with the same provider yet I have zero signal all the time and my wife phone is great. Is this common? To say the phone cost me over £1000 I'd expect to be able to text and call from it surely?
0 Likes
7 REPLIES 7
WelshPaul
Troubleshooter
Options
Tried placing the SIM in the second SIM slot? Maybe the IMEI was barred, faulty SIM or phone?

My advice comes from being a UK Samsung iPhone user.

Current Devices:
  • iPhone 14 Pro 256GB Deep Purple
  • Samsung Galaxy Buds+ > Model: SM-R175.
0 Likes
Bigtasty65
Hotshot
Options
Have you checked the phone settings on both phones are identical?
Under phone settings tap on Connections and check both phones are identical on all settings. Plus, even swiping down from the top of the display and make sure the Mobile Data is toggled on and Flight Mode is turned off.
Also check that the SIM card is inserted correctly. If all else fails, maybe even try a factory reset, to set the phone up from scratch again might help.
0 Likes
DannyStarbs
First Poster
Options
Yes mate... no change
0 Likes
DannyStarbs
First Poster
Options
I have done all of this. Even the reset. Sadly, no signal. The annoying thing is I will have signal then it will dissappear for an hour then I will get 10 minutes of signal then it goes again. Really randomly
0 Likes
Majorj0nny
Pathfinder
Options
I had the same thing with the 21. After a few return trips to the service centre they eventually replaced the motherboard which fixed the issue.
0 Likes
Bigtasty65
Hotshot
Options
Might be worth inserting your SIM card in another device. Just to see it's not the card at fault. Otherwise best doing what Majorj0nny has said and return it to a service centre for inspection.
0 Likes
Aktaujames
First Poster
Options

I had exactly the same thing, no signal despite the sim card being detected - and it would come back for  10 minutes every few hours before dying again. I decided to put some contact cleaner on the sim and inserted and removed the sim card repeatedly to clean the contacts inside the phone too (with the phone off of course). I left it for a while so the contact cleaner dried and I have had no problems since.

0 Likes