Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Samsung Ultra S21 the Galaxy Store is not working and I see apps not compatible for the version error on Play store

(Topic created on: 04-06-2021 06:33 PM)
Adil Musa
Apprentice
Options
Mobile Apps & Services

Hi,

I just bought the Samsung ultra s21 but the galaxy store does not seem to work for me. It tells me it's not compatible and half of the apps do not work, such as Call of Duty and Adobe Photoshop saying the same thing. Any reason why this is? and is they a way to fix this? 

0 Likes

1 Solution


Accepted Solutions
Solution
Pugs1957
Superuser I
Superuser I
Options
Mobile Apps & Services
Thanks for your reply. I believe your compatability issues are because the phone is a fake. The processor it has is 32bit, it should have a 64 bit processor. Where did you get it?

View solution in context

14 REPLIES 14
antikythera
Hotshot
Options
Mobile Apps & Services
Use Google Play store instead it's better managed and more secure. Samsung's Galaxy Store has clones of apps alongside genuine ones with the same name submitted by end users rather than the original developers. These end users are charging for stuff that is normally free and not updating the apps.
0 Likes
Joeeye
Hotshot
Options
Mobile Apps & Services
That is quite unusual, only thing I suggest is deleting the app data of the galaxy store and see if it helps.
0 Likes
Members_ICVdhAt
First Poster
Options
Mobile Apps & Services

I'll give that a go, but wondering why I can't access half of the apps available on Play Store. Keeps telling me this version is not compatible with this device.

 

Also, I don't have the software update in settings, so wondering how do I update the phone.

0 Likes
Pugs1957
Superuser I
Superuser I
Options
Mobile Apps & Services
Please download Device Info app from Play Store and tell us what processor it says the device has.
0 Likes
Members_ICVdhAt
First Poster
Options
Mobile Apps & Services

The processor says ARMv7 Processor rev 3 (v71)

0 Likes
Adil Musa
Apprentice
Options
Mobile Apps & Services

all the settings seems to be old for some reason in the device info :S, I don't have the software update button and all the apps keeps saying the device not compatible for this version.

 

The processor says ARMv7 Processor rev 3 (v71)

Solution
Pugs1957
Superuser I
Superuser I
Options
Mobile Apps & Services
Thanks for your reply. I believe your compatability issues are because the phone is a fake. The processor it has is 32bit, it should have a 64 bit processor. Where did you get it?

View solution in context

Adil Musa
Apprentice
Options
Mobile Apps & Services

Gosh! I've been scammed then, I purchased through Facebook Market,  the guy delivered it to me in hand and it was all sealed so couldn't check the device. Looks like I made a loss in this and can't do anything about it 😞

Thanks for letting me know.

0 Likes
Pugs1957
Superuser I
Superuser I
Options
Mobile Apps & Services
I'm so sorry you got scammed. There are some not very nice people around 😕
0 Likes