Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung Pay

(Topic created on: 30-01-2021 06:42 PM)
Andyu1968
First Poster
Options
Mobile Apps & Services

My S21 Ultra is showing a German text error when opening Samsung Pay.

The text is "Bezahl mit einem Swipe." and "Leider ist dein Samsung Smartphone derzeit fur Samsung Pay nicht zugelassen".

There is no option to reset or change language.

How do I use Samsung Pay on my new phone?

0 Likes
6 REPLIES 6
Steven9761
Helping Hand
Options
Mobile Apps & Services
SETTINGS/GENERAL MANAGEMENT/ LANGUAGE AND INPUT/LANGUAGE... If the default language is set to German, change it, and see how it goes. 😊
0 Likes
Andyu1968
First Poster
Options
Mobile Apps & Services

Hi Steven,

That didn't work. Translating the text is says "Unfortunately, your Samsung smartphone is currently not approved for Samsung Pay", I'm amazed a flagship smartphone is not compatible with the standard way of buying items!!

Steven9761
Helping Hand
Options
Mobile Apps & Services
I think SP is going through some firmware changes, which will probably be updated at some point soon. I think future phones will only use NFC for payment transactions. there is another acronym that is being phased out. I believe that thing being phased out replicates the magnetic strip on the card, whereas NFC reads the chip.
0 Likes
Lukasz
Navigator
Options
Mobile Apps & Services
Wait for network settings update from your operator. to do that turn off WiFi. just be patient it might take some time. After that you be all good.
NickyB136
First Poster
Options
Mobile Apps & Services
I had same issue. Now resolved. Not directly to do with SP. Needed the "service provider software version" to be updated to be country specific. Should normally happen when first set up your phone. Doing a sim swap after 24 hours of having the phone triggered the update for me. SP works fine now.
Gemma6
First Poster
Options
Mobile Apps & Services

I've just had the new z flip and having the same problem. No matter what I do its still in german

0 Likes