Open search

Samsung Health not tracking workout distance after September Update



I have problem with my Galaxy S9 and Samsung Health app. After last app update (this which includes these horrible notifications) application aren't tracking distance in workouts. I'm using rollerskating workout and until this update everything worked fine. I have tried other workouts and walking or running are working properly with distance counting, but other workouts (I have checked ~5 other) are counting time, kcal, map is recorded correctly but distance is always 0.0km.


Don't use standard replies please. I have cleared app data, uninstalled, cleared cache in bootloader and installed again without success - still same problem. It's app problem after some of september updates.


Exactly. Right now I have got version   and it is rubbish.


😞 Same problem! 

New Member

Try going into settings and apps and Samsung health then allow location (when app in use). I had the same issue after a bike ride then saw this thread. I changed the setting and started a walk and the distance started recording. Yet to try on a bike ride but think it may be the fix.


I have the same issue on Samsung S9+. My phone is capable of measuring distance ONLY for walking and running. All other activities show 0.0 km distance (so far, I tried skiing, roller skating, inline skating, and cycling).
Everything worked fine before the last large update. I assume, it is the same September update problem.
The same problem is with the S Health on my Watch Active 2. I tried cycling and it also did not track the distance. The only activities that work are walking and running.
S Health version - still no improvement.
It is very disappointing. The latest updates of all Samsung software have plenty of bugs.


I have the exact same issue as some of you have described on here.. it would track my walking by not cyclying route or distance.


I have just gone into my Samsung settings, Apps, Samsung Health setting and i noticed Location Information was off. I tried swicthing it to On and the setting crashed, tried again and it went back on.


Now that i have gone back to Samsung Health and gone to Bike Ride the location came on and mapped my current location.


I can only assume the updated must have disabled location service in the app.


I just need to test it on a ride now.

View solution in original post


Wow amazing pal. This is really helpful indeed. 


I will give it a try....hopefully it works!






I have tested it and IT WORKS now!!! 


Make sure you also go enable location in:

Settings>>Apps>> select the Samsung healt app through the icon (not the srttings gear icon) and enable PERMISSIONS (Location).


All the best!


Thanks for the info. My "location" option of the SamsungHealth app was disabled.
I have turned it back on and tried cycling and skating activities. However, it still did not track the distance. There was the gps icon with text "not in use" inside the app for every outdoor workout I tried.
I restarted my phone and tried to clean cache data. Nothing helped. I really do not want to factory-reset my phone =(
It drives me mad.


ASCX, please DO NOT factory reset your phone.


I promise you I had the same problem and I have tried now and it works. I have been using it for over 1 week now.


Go to:

1) Settings/Apps/ this is where it gets tricky.

2) Search for the "Samsung Health" app (do not touch anything yet). You will see the settings nut icon.

3) Touch the icon and enable "Location information"

4) Go back and now search for the app again but THIS TIME TOUCH THE SAMSUNG HEALTH ICON OR NAME

5) Scroll down to "PERMISSIONS". You'll see "enabled" and "disabled" functions

6)  Enable LOCATION




Try again to cycle and you'll see that after a few seconds the speedometee starts moving....OH! Enable phone location before cycling!


If in doubt. You can write to me to and I can send you the steps screenshots.

Top Liked Authors