Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung Galaxy A40 - No sim inserted

(Topic created on: 27-06-2020 04:25 PM)
Archers
First Poster
Options
Mobile Apps & Services

For the last 6 weeks; my phone has been showing this message and doing it more frequently.   

I contacted my sim provider who provided a new sim.  Sadly it has continued sporadically display the 'no sim inserted' so no calls can be made and I cannot receive them. 

 

The concerns for me is I have an elderly, very ill family that call me through out the day as well as the doctors, carers, chemists and family so I cannot have a phone that is not reliable.  I only got this phone in January at to me a very expensive price, this was the most I have ever spent on a phone, so I am extremely disappointed at the moment. 

 

I did try to resolved this via Chat Live, but they asked me to reboot, which I did, to then try and get back in touch it is now saying too busy, try later and I am now hanging on to their call centre.  I did say to Abigail on live chat that this was my concern, but she said it would be fine!   I have done all that has been suggested, but it is still not working.     

 

I am so upset now as I feel this is just being brushed off and I am aware numbers of staff are lower, it is a difficult time although with technology I am sure that staff could be set up at home if needed. 

 

As a careworker myself, my phone is vital to ensure I can provide the support to my clients espcially when an emergency and to my mum.   Has anyone else had the same issue with this happening?

 

 

0 Likes
0 REPLIES 0