Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Very poor spin on washing machine WW90TA046AE/EU

(Topic created on: 2 weeks ago)
Susan49
First Poster
Options
Home Appliances

After 14 minutes at 1400 rpm, my washing is still pretty wet.  My previous AEG machine dried the clothes much better under the same conditions.

I have to spin them twice to get them as dry as before.

Useless service from Samsung.. on the website it says that if it spins at all, then there's no problem with the machine.  Hopeless trying to speak to anyone.

Wish I hadn't bought this machine.

0 Likes
2 REPLIES 2
andy_in_ireland
Voyager
Options
Home Appliances

what duration is it spinning for at 1400rpm? - I bet its not the full 14 mins at 1400rpm. 
I have the series 5 WW90T534 - on 'mixed' it starts emptying around 9 minutes and going into a spin (thats if the drum is balanced OK, if its not balanced it will hang at 9 minutes that feels like it is for ages!) - and only like for the last minute will it really rev up to 1400rpm and then as quick as that the cycle is then finished! 

I wish they wrote the software that it will spin for near enough the 9 minutes at the full spin speed - then they would really come out dry ... more than creased to high heaven as well ... but still a lot dryer  than they do . 

Other than that have you made sure that the filter at the bottom of the machine is totally clean and that the grey waste hose at the back of the machine is not pinched or kinked?

0 Likes
Susan49
First Poster
Options
Home Appliances

Hi Andy,

Thanks for your response. Yes, it IS spinning for 14 minutes and the machine is not even amonth old so the filter is clean and we've checked the hoses.  I finally managed to get through Samsumg's appalling "self-help" on-line procedure and have a visit booked from an engineer.  I had to lie to get that far........ the site asks "does your machine spin when empty?" and if you answer 'yes', it tells you that there's nothing wrong with it!

I spoke to the local engineer and he said the machine was probably not spinning at full speed (even though it thinks it is!!), and this is a common fault which he can rectify when he's here.