Open search



Samsung Ecobubble 9kg which is just coming up on 2 years old keeps stopping mid wash. No debris issues, no hose issues. Sometimes I get a full wash with no issues and then other times it stops and I have to turn the machine off and reset to Rinse & Spin to get it to finish. Any ideas what is wrong?

230 REPLIES 230
Same problem here.
We bought our Ecobubble in Dec 2014 ( Now 3 years old since 6.Dec 2017).
So I called repairman and without even coming to check, he said it must be the heather element. It wasnt, then he changed the computer in it, still had problems. Now yesterday, it cave up.
Already have been i contact with the store that sold us this washer and they say we have no warranty on it anymore and we have to buy a new one. FML

I am afraid I have the exact same issue and live in France too. I would hence very much like to know to which email I can send an email to try to get this fixed. Please can you share the email address to use in France?


I am exactly in same situation. 

My washing machine began to have problems, just 2-3 weeks, after two years, when the warranty ran out. I don't know what to say.

The funny thing is the following:

We bought 2 things: A washing machine and a dryer. Both of them began having problems, exactly at the same time, just 1-3 weeks after two years. HOW IS THAT POSSIBLE? They have no connection to eachother. What is the chance, that two diff appliances break at exactly the same time? (Could they have a secret timer? ).  I am not suggesting anything, I just thing that it's crazy, that they both break at exactly same time.

They were pretty expensive, and I also thought that they would last longer than 2 years.


HI Jw77,


I am having the same problem with my Samsung machine, it is the same model as your one. I was wondering if you could talk me through how you went about replacing your PCB.

E.g where you bought it?

how to replace the PCB on the machine?


Any help would be greatly appreciated.


Hi Taz11,


My machine is an 8kg, model number WF80F5E5U4W/EU.

I managed to source a replacement PCB control for my washing machine from, it did cost £150 + a couple of pounds for next day delivery. It took me 10mins to change, all you need is a 'phillips' screwdriver to remove the 2 screws on the rear of the washer lid and the PCB is visible to the front right of the washer, remove the wires (which are plugged), 4 screws hold the board in place and fit the new one, very easy.

This was done back in September 2017 and still working without issue.

I hope this helps.


I've posted on here before with the same problem.

The engineer replaced the PCB-when he tested the machine on a wash the problem was still there. He came back and replaced the motor which fixed the problem.

He also said that when he tested them neither component showed a fault.


Good luck in getting it sorted.


Same issue here in Australia. I have 10kg Washung Machine Bubble Wash VRTPlus (WW10H8430EW) and its stopping a stadard 1hr 7 min wash around the 50 min mark. When I'm lucky, pausing then unpausing will get it working after 3-4 attempts.

Not acceptable though. 2years and 8 mths after purchase and it looks like a very common problem.

What can I do Samsung?




I have purchased a new PCB to fit but cant seem to get the top of my wahing machine. It is a WF90F5E304W. I have removed the 2 screws at the back and removed the detergent drawer but it seems stuck at the front. I have tried to slide it from the back but it is still stuck. I have looked on Utube but they all seem to slide out. I am in UK. Any advice greatly appreciated.






I'm sure mine just slid out after removing the two screws, I don't recall having to remove the draw either. 2 screws and off the lid came. Are you getting any movement on the lid or is it stuck fast?


Morning Folks

Glad I found this thread as I was having a similar issue when my mrs started complaininga couuple says ago saying ‘your fancy expensive machine keeps freezing between washes’

I thought to my self, another 600 quid down the drain.

Initially a year ago I had an issue with a door switch, and fortunately had a spare., so I swapped that out last night. Tested again, same thing, started and then paused and no joy.

Then I found this thread n hour ago, praise the lord.

So decided to get the manual out and run through the default Samsung calibration to clear any memory

Powered on, and entered into CLB mode and proceeded to sit and watch to see what was gonna happen.

Gggrrrrhhh nothing..

I could see the drum attempting to move and then appearing to Jam.

Mmmm I thought..

So I stopped the CLB, opened the door and stuck my hand in and tried to move it by hand, like a kid as you do :smiling-face: , and then I noticed it was propa PROPA stiff and was just refusing to rotate.

Well I thought, if the drum is f...d then I’m just gonna force it around with force and see what happens. Eventually after applying some brute force, I managed to get it to turn slowly and then gradually I started to move it clockwise and anti clockwise, for about 3-4minutes and I was just listening for the sake of listening to the rotation and to also feel if I could feel anything catching.

Eventually it started to kinda free up and I basically just kept spinning and spinning until I noticed it feeling kinda free.

So I ran the machine in calibration mode again and the drum then turned and rotated both clockwise and anti clockwise for the 3minutes. The CLB mode then completed successfully.

Keen to get testg again, I then proceeded to squeeze out the water from my kids clothes sat in the sink from the previous Jon that kept freezing up (to free up any excess weight) and then I reloaded the machine again, bit by bit , and then I ran the Rinse and Spin.

So far I can say I am into my 3rd rinse and spin (max speed 1400rpm) and all seems ok, fingers cross.

I’ll keep you all posted.

Ps. Tip 1
Stick ya hand in the washer and see if the drum is free to move.

Ps Tip 2
Run CLB mode

Top Liked Authors