Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Auto dispense problem.

(Topic created on: 16-10-2020 10:37 PM)
37014 Views
Ktxx
First Poster
Options

Hi, I have a Samsung washer dryer with the auto dispense function. Up until now it has been working absolutely fine but I’ve noticed that my fabric softener wasn’t loading when it should. I’ve done a drum clean, cleaned all compartments etc and still nothing. This evening I’ve run a rinse and spin to see and have no fabric softener in the machine yet the the dose indicator is showing full when it’s not! There’s also a chugging noise as if it’s trying to dispense but nothing is obviously there (this noise also happens when it was full) I’m at a loss as to what I’m to do?? Has anyone else experienced this? 

0 Likes
71 REPLIES 71
Websters
Apprentice
Options

I am also having the same issue with my 6 mth old machine. Softener auto dispenser not working.... If this is a design fault (which it seems to be) then they can come and take it back! 

0 Likes
BrassiestClover
Student
Options

Exactly the same issue less than 2 years old. Been on to the help people and as I have had a repair i now need to jump through additional hoops to get it fixed. This machine has been no where near as good as previous. The biggest issue is the random long time for washing to take place- can go all flippin day. I really would prefer a fixed time....

0 Likes
andy_in_ireland
Troubleshooter
Options

@Btvcon wrote:

Engineer came out and replaced the entire assembly drawer and housing. The housing which the drawers sit in contains the valve controls at the rear which control when and the amount of detergent and conditioner is dispensed. This has fixed the problem and my machine is now working as new. It would appear that it was not a PCB problem in my particular case.

I have attached the exploded view document I found online which shows the housing assembly and drawers in detail.Assembly Housing.JPG

 


Question is though in another 6 months is same thing going to happen again - will you have to keep getting an engineer out every 6 months?

0 Likes
andy_in_ireland
Troubleshooter
Options

Our machine WW90T534DAW look at the softener port on the left hand side after just 4 months use! - see how different it looks to the detergent port / seal on the right hand side, thats the problem I reckon, I reckon the autodispense feature works fin with liquid detergent , however there must be something in the fabric softener that the system dont like. Here is another observation, you know these days fabric softeners are very thick, not like the old days when they were runny and these days they say ''concentrated fabric softener' yet in the old days they did not say concentrated and was not concentrated , do you think these days maybe we should be mixing the 'concentrated' fabric softener with water FIRST before adding it to the fabric softener auto dose dispenser compartment so it thins it down and runs through the valve/pump easier and not clog it up? - its just a thought - i might try it next time I add some fabric softener (it will make the fabric softener last longer as well)  Take out your whole auto dose drawer (see owners manual, you have to push down the blue catch on top of the drawer to remove drawer  totally as you are pulling the drawer out) now look right up at the back at the valve ports for the fabric conditioner and detergent - does yours look like this all dirty and blocked on the left hand side like ours? 

ww90t534daw autodose.jpg


0 Likes
Jip1000
Student
Options

Hi where did you get this diagram I cannot find anything online relating to the auto dose pump. Thanks 

0 Likes
Jip1000
Student
Options

Hi where did you find the auto dose diagram I can’t find anything online regarding parts for it. Thanks 

0 Likes
andy_in_ireland
Troubleshooter
Options
0 Likes
Gavin3
Journeyman
Options

Hi Andy, this should help you! 


https://almade.es/wp-content/uploads/2019/09/EXPLORADOR-WW10M86GNOAEC-VERSION-01.pdf

 

The entire pump is part no DC97-19821A. You’ll find it on the Samsung spares website.

andy_in_ireland
Troubleshooter
Options

@Gavin3 wrote:

Hi Andy, this should help you! 


https://almade.es/wp-content/uploads/2019/09/EXPLORADOR-WW10M86GNOAEC-VERSION-01.pdf

 

The entire pump is part no DC97-19821A. You’ll find it on the Samsung spares website.


brilliant thanks

0 Likes