Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Wi-Fi calling problem

(Topic created on: 10/02/21 18:03)
PAD
Explorer
Options
Galaxy S9 Series
S9 originally supplied by EE had Wi-Fi calling, switched providers to Sky mobile and now Wi-Fi calling doesn't work (unless roaming is set to abroad which means changing the settings constantly).
Anyone got any ideas how to resolve this please?
0 Likes
Reply
9 REPLIES 9
Easty
Helping Hand
Options
Galaxy S9 Series
Do Sky mobile support wifi calling ? Not all carriers do
Samsung Galaxy Note 10 Plus 5g
Samsung Tab S6 Lte 256gb
Samsung Galaxy Watch
0 Likes
Reply
PAD
Explorer
Options
Galaxy S9 Series
Yes they do. I had it on another S9 previously and currently on my ZFlip. (It's my wife's s9 with the current issue.)
0 Likes
Reply
papashaun
Smooth Operator
Options
Galaxy S9 Series
Hi - maybe silly question 😀 but has your wife asked Sky to turn it on for her mobile plan ? Although the carrier supports it you may have to ask for it to be turned on
PAD
Explorer
Options
Galaxy S9 Series
Fair comment, will check.
0 Likes
Reply
PAD
Explorer
Options
Galaxy S9 Series
Sky mobile Wi-Fi is on but Sky state some phones provided by other networks may not be compatible, this is the case here. EE seem to have made setup adjustments that prevent the S9 from working fully with other providers.
Whether a factory reset would put it back to Samsung settings or not I don't know. That's an awful lot of work if it didn't work (even with backups & restore) and wouldn't go down well!
0 Likes
Reply
papashaun
Smooth Operator
Options
Galaxy S9 Series
Yeah guess the various carriers do put some of their own stuff on !

Since you know is turned on by Sky could try :

I did have a problem on my Note 10+ with WiFi Calling when updated to Android 11 UI 3 - don't know if will work on your S9 ( or If the settings will be in the same place )
Go in to Settings - Connections - Mobile Network first check mode is set to Lte/ 3g / 2g ( I believe you need 4g ( Lte ) and to be connected to WiFi) Then go to Network Operators ( is on same settings page ) turn off Automatic and will then ask to scan for available networks - tap Sky on the list. Then check if WiFi Calling back
This worked for me on Vodafone but not for someone else
Only other suggestion I could make is turn phone off- take out Sim - re insert Sim and Restart phone
Hope one of these work
0 Likes
Reply
papashaun
Smooth Operator
Options
Galaxy S9 Series
Just another thought - if these don't work might be worth clearing the phone's cache ( don't lose any personal info on the phone ) worth checking on Google or somewhere how to do it but THINK is power off phone - hold vol up and power button at same time till phone boots up - should get a menu at top - use vol up / vol down buttons to scroll up or down - highlight wipe cache and use power button to select - wait a moment or two to give it time to clear it then restart phone.
( As I say would just check on Google or somewhere for the procedure in case I'm not quite right )
0 Likes
Reply
PAD
Explorer
Options
Galaxy S9 Series
Thanks for suggestions, unfortunately they made no difference. Worth a try though.
0 Likes
Reply
papashaun
Smooth Operator
Options
Galaxy S9 Series
You're welcome- sorry they didn't help - hopefully someone else will have an answer 🤞
0 Likes
Reply