Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S9+ no missed call alerts

(Topic created on: 03-04-2018 08:54 AM)
Damienw1
Pioneer
Options
Galaxy S9 Series

Hi I’m having issues with no missed call alerts the only way to solve it seems to be to turn off caller Id and spam protection as was advised on Xda forums it seems there are many others with this problem anyone know any other work around as that feature is important to me?

 

And obviously getting no missed call alerts is not an option I’ve already missed some important calls!!

 

S9 plus single sim tried factory reset wipe cache etc still the same really not happy about it to be honest and I didn’t expect this after spending this much on a flagship 

 

Thanks 

55 REPLIES 55
Grubb3r
First Poster
Options
Galaxy S9 Series

I think I fixed this on my phone. I went into the regular settings (the cog button), "notifications", and on the top right, I went to "Advanced". I found that my Contacts were blocked from notifications, which included missed calls. I changed this and it seemed to have worked!

0 Likes
Oommpa
First Poster
Options
Galaxy S9 Series

I got my 9 plus in April and just about 3 weeks ago it stopped showing missed calls. I don't have the caller ID and spam options in my settings.  How do i fix this issue? 

0 Likes
Paulos
Apprentice
Options
Galaxy S9 Series

Have you cheked the right place for spam protection?

Open your phone dialler, press the 3 dots, then settings, and its about half way down "Caller ID and spam protection"

Its the only way I can recieve missed call notifications on mine.

Wish Id stuck with my S7 edge now

Oommpa
First Poster
Options
Galaxy S9 Series

I don't have the "called ID & spam protection" option listed. Screenshot_20180622-120833_Phone.jpg

 

0 Likes
houseofboyd
First Poster
Options
Galaxy S9 Series

This worked for me as well.... :smiling-face:

0 Likes
jaygarcia075
First Poster
Options
Galaxy S9 Series

I was having the same problem no missed call notifications on notification bar or lock screen. I uninstalled clean master and security master apps just now and began receiving missed call notifications immediately. 

If you have these apps I would uninstall immediately. If you do not have these apps check other apps you have installed around the time you noticed the issue. 

Oommpa
First Poster
Options
Galaxy S9 Series

Unfortunately I have no idea what app i downloaded at that time. 

0 Likes
jaygarcia075
First Poster
Options
Galaxy S9 Series

Had the same issue, uninstalled clean master and security master apps. Working fine now. 

MommaChoate93
First Poster
Options
Galaxy S9 Series

I'm pretty sure I may have found the solution...not 100% sure yet but we shall see. I got the s9+ 2 months ago. Had the same issues.  There was no notification or anything saying when I had a missed call so that only way I could tell is if I go into my call logs and was about to call someone... Or something like that. Which is Very aggravating. Especially when me and my husband both have the phone's and I get mad at him because I call him a million times in he will never now and he will get my when I don't call him back but unless I see that I have a missed call or something I'm not going to check my phone. So let's get to it....So what I did was....

1. Go into settings 

2. Click on notifications 

3. In the top right corner it should say ADVANCED in blue word.

4. Click it! Should see 3 blue dots now in the top right corner. Click it!!

5. Click show system apps...

6. Scroll down until you see Contacts!!!....click it.

7. Make sure app icon badges are on!... You should say 3 categories 1 of them saying missed call...click it.

8. I clicked where it says important & put it on urgent!....

9. Clicked on sound & picked one.

10. Turn on app icon badges.

Put it to the test let me know if this helped you out. Thank you guys

0 Likes
MMat
First Poster
Options
Galaxy S9 Series

I have fixed mine.

Yes, the problem was in the Security Master app, but you don't need to uninstall it.

Just go to this app, tap on "Notification cleaner" part of it, then on setting sign.

There you will see a list with apps from which Security Master doesn't allow notifications (Apps - Don't disturb).

Uncheck those you want (Contacts, Massages etc.). They will appear on the bottom list - Apps - Notifications allowed. 

You are done! 🙂