Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Mobile data not working after disconnection from WiFi

(Topic created on: 11/07/18 08:46)
xxmicrocutsxx
Apprentice
Options
Galaxy S9 Series

This fault occurred after the most recent update of my S9. When my phone disconnects from a WiFi network (whether manually or once out of range) my phone will display either a 4g or H+ but no data is sent or received and apps/browser will confirm the phone is offline. The only way I can get mobile data to work again is to either toggle it off and on or go into flight mode for a short time.

This happens on any WiFi network (home, work, public) and I have the auto WiFi switcher features tuned off. Has anyone else come across this issue? I reset my network settings but that hasn't helped. Would prefer not to have to factory reset to correct a fault which Samsung seem to have introduced themselves. 

Thanks

53 REPLIES 53
ChrisW
Explorer
Options
Galaxy S9 Series

I set up another APN profile which won't be overwritten by Samsung's auto provisioning service after software updates. When the latest software update installed, it prompted me to reconfigure my APN settings using pre-configured settings - I was able to say no, and kept the old config, but it would be useful to know I have a known good version of the settings for my telco.

 

Incidentally, what was the incorrect APN info the phone configured? Hopefully @ChrisM can feed the info back to Samsung devs...

0 Likes
Reply
basam
First Poster
Options
Galaxy S9 Series

I have same problem. Therefore s9+ dual sim will be my last phone. I will never buy samsung phone never. It has serious problems and very very very slowly update package is taking off...wretched.

0 Likes
Reply
kate331
New Member
Options
Galaxy S9 Series

i found a current fix, well somethin thats worked for me. i reset my access point name to do this you need to go to network connections click access point reset to default click the one that matches your phone whether its payg for pay as go or contract wap option for contract (hope this helps)

0 Likes
Reply
Stevemyland
First Poster
Options
Galaxy S9 Series

Hi.

I had this fault and found a fix for my problem. I cant guarantee it will work for you people but it's worth a try. My provider is vodafone. I reset my network settings which was easy. I then went under Settings, connections, mobile networks, access point names. For some reason it was set to vodafone PAYG. I changed this to Vodafone contract internet. This has worked perfectly since. I can enable  'mobile data' from the pull down menu and when I'm out and about and get an internet connection all the time. I hope this works for you and everyone else.

0 Likes
Reply
cpoll
New Member
Options
Galaxy S9 Series

Where do I find VoLTE enabled? Also, I have found the data service is disconnected, would that be similar?

0 Likes
Reply
Stevemyland
First Poster
Options
Galaxy S9 Series

Hi. I'm not sure where you enable VoLTE. I believe this is only available if you have EE as your service provider. If that is the case you will need to pop into a shop as I'm vodafone.

My data service was not working either and I tried a reset and it's worked perfectly since. I'd give that ago. 

 


 

0 Likes
Reply
Beaner
First Poster
Options
Galaxy S9 Series

I have a different Samsung model but was having the same issue. I went to Settings>System Updates>Update Profile and it seems to have done the trick.

0 Likes
Reply
ChrisW
Explorer
Options
Galaxy S9 Series

Depending on whether you have a SIM free or carrier-locked model, the VoLTE setting may not be available. On my SIM free device, it's in Settings -> Connections -> Mobile Networks and is the option called "VoLTE Calls". When enabled, you should see your phone stay on 4G when calling, instead of drop back to 3G.

0 Likes
Reply
TroyT1975
New Member
Options
Galaxy S9 Series

Just got updated to Android V9 on my Galaxy S9 and this problem got introduced, after VoLTE had been working flawlessly on the previous version.  Had to turn off VoLTE or no Mobile Data at all, update on my phone was approximately Feb 1, 2019.

0 Likes
Reply
Homeandhome8
First Poster
Options
Galaxy S9 Series

I had same problem and solusion is to go to Mobile networks--->access point names--->on to your Sim card---->and the delete numbers under proxy server and port, only these are needed. Then press on three dots in upper coner and save.
Thats it. Then you can use your phone internet again.

0 Likes
Reply