Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy S9 plus screen flicker

(Topic created on: 03-03-2019 09:48 AM)
13954 Views
Iaian
Apprentice
Options

Since this stupid update my screen seems to flicker on incoming and outgoing calls..its like I have screen damage but my phones brand new at only a week old..I have also noticed the same problem on my wifes s9..this update is seriously rubbish..Samsung needs to fix it seen as were all using their pricey phones

43 REPLIES 43
1Mohit1
Apprentice
Options

For me, nothing seems to work. Though mine has a simple weird solution of keeping the brightness around 15% but it's really annoying to use your device in outdoors then. So, I actually found a little workaround which seems to be working for the time being (though it has it's own limitations but still). So this PWMfree app from xda seems to solve this issue to an extent.

https://forum.xda-developers.com/galaxy-s9-plus/themes/utility-amoled-pwmfree-application-t3898070

I would say you guys give it a try and it should help as a temporary workaround. Thought it's still bad on Samsung's part to have not released a fix to this weird issue in the first place.

0 Likes
unruptured
Apprentice
Options

My phones working perfectly fine seriously after what I did. Not sure what might have caused that ***** flickering screen. 

 

We had the same issues... whenever I change the brightness of the screen it kinda fades, flicker and shows black lines or green screen. But after I did those things it never came back. I just made sure I dont lock/unlock my phone with the hard button. (Well not until now that it seems to have been fixed. - I removed lift to wake too by the way).

0 Likes
badarsir
First Poster
Options

Sailing in the same boat, Same problem with my s9plus. But Samsung people seems to have gone deaf on this problem or they r not qualified enough to tackle this issue, created by themselves. 

0 Likes
GeorgioD
First Poster
Options

So, I know this is not the best solution and it may have been given already. But what I did is turning on Always on Display (AOD) permanently with the birghtness setting of AOD to low. I also changed the setting that you only see the home button so that you don't get bothered by most of the AOD. My S9 funtions sort of normal now, though it's still insane Samsung does this... 

0 Likes