Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

After Pie update, Device care keeps flagging up high battery usage for an app I don't want to put to sleep.

(Topic created on: 28-12-2020 06:37 AM)
Matthew-Long
Apprentice
Options
Galaxy S9 Series

Hi, since updating my S9 to pie update  all has gone smoothly apart from one annoying issue with the new 'Device Care' app. 

When I go into setting, it flags up high background battery usage on a couple of apps that I need to keep awake. The only option seems to be to put it to sleep. I can't see anywhere that you can select theses apps to be ignored . Meaning this battery usage warning is there all the time  and my battery circle in the Device care is about 85%

I have no battery life issues. The Pie update seems to have improved my S9 battery life.

Anyone throw any light on this? I just want certain apps to be ignored for high background usage  so it doesn't keep nagging me  Lol  

0 Likes
9 REPLIES 9
AntS
Moderator
Moderator
Options
Galaxy S9 Series

Hi @Matthew-Long:smiling-face:

 

The 'Unmonitored apps' and 'Always sleeping apps' options have been integrated in Pie. Are you able to remove the apps you want to keep awake from the 'Sleeping apps' list?

0 Likes
Solution
Reginard
Pathfinder
Options
Galaxy S9 Series

I had that problem and after a lot of playing about, I think I've fixed it....

 

Settings

Apps

scroll to the app you need to configure and select it

Battery

Optimise Battery Usage

Change "Apps not Optimised" to "All"

Scroll down to the app and move the slider to off

Restart the phone

 

(it didn't disappear immediately on mine but it doesn't seem to have come back)

 

Good luck :hand-with-index-and-middle-fingers-crossed:

 

View solution in context

Matthew-Long
Apprentice
Options
Galaxy S9 Series

Hi. Thanks for replying. I can remove it from the always sleeping apps, but if I do, it just keeps nagging about background battery usage  and 'fix now' 

I would like it to still monitor my apps, but ignore ones I don't want it to tell me about. 

 

Battery life is much improved after Pie update 🙂 

0 Likes
Matthew-Long
Apprentice
Options
Galaxy S9 Series

Thank you. I will give that a try  🙂 

 

0 Likes
Matthew-Long
Apprentice
Options
Galaxy S9 Series

@Reginard wrote:

I had that problem and after a lot of playing about, I think I've fixed it....

 

Settings

Apps

scroll to the app you need to configure and select it

Battery

Optimise Battery Usage

Change "Apps not Optimised" to "All"

Scroll down to the app and move the slider to off

Restart the phone

 

(it didn't disappear immediately on mine but it doesn't seem to have come back)

 

Good luck :hand-with-index-and-middle-fingers-crossed:

 


This seems to have done the trick  Thank you! Time will tell! 🙂 

NotaTechie
First Poster
Options
Galaxy S9 Series

After spending some time on the phone with Samsung trying to find the answer to this question they informed me that this is no longer an option. Apparently the Pie update does not allow you to designate apps to not be monitored anymore. I'm not a fan! I asked them to please put this back in the next update. My cell carrier has also put this request in with Samsung. I can't believe they didn't catch that this would be an issue.

0 Likes
Hazza1
First Poster
Options
Galaxy S9 Series

Yes. This worked...been 4 days and no more annoying app reading high battery so thanks for the workaround and def give it a try. ( Galaxy note 9)

0 Likes
dodito
First Poster
Options
Galaxy S9 Series
Really helped! Thanks
0 Likes
Volensventus
First Poster
Options
Galaxy S9 Series

Thank you!!!

0 Likes