Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

4G connection stops working on Galaxy s9+

(Topic created on: 21/09/18 21:58)
alex-tavares
First Poster
Options
Galaxy S9 Series

I've recently bought a galaxy s9+ and it's behaving weirdly while on 4G. For some reason the connection becomes really fast and then stops working at all, but the 4G symbol keeps showing up. The weirdest thing about it is that it dosen't happen while on HSDPA or LTE Advanced (4G+).I have tested two carriers and both show the same issues. I have no idea what is going on. Does anyone experience the same issues?

0 Likes
Reply
2 REPLIES 2
BandOfBrothers
Superuser I
Superuser I
Options
Galaxy S9 Series

Does your SIM card work ok in another phone @alex-tavares ?

 

Does this happen in one particular area or everywhere you go  ?

 

A Samsung Service Centre will be able to help you further with this situation by performing a diagnostic on the phone. 

 

 




Current Phone ~

Samsung Note 20 Ultra 5G SM-N9860_256Gb SnapDragon 865+

Samsung One Ui 3.1/ Android 11.

alex-tavares
First Poster
Options
Galaxy S9 Series

Thanks for your answer @BandOfBrothers . I've just read this topic Not connecting to mobile data S9 and I think it's the same problem. Because now that I'm not in an area where Volte is available it works fine. But just realized that I'm having those issues at work and places where Volte is available. I'm gonna try to disable it and see if it works.

0 Likes
Reply