Support

Open search

USB connected disconnected

Apprentice

I've noticed that I'm getting the USB connected/disconnected message and yesterday it was saying that moisture was detected but there's no way that anything got in the connection. And now it won't charge

110 REPLIES 110

I had the same problem with my Galaxy Tab S6 which I only had for 5 days. It only started happening TODAY.  So Samsung wanted me to ship it back to them for repair. When this message happens you can't turn off the screen with the power button and when you turn off the tablet and plug in the charger the usual charging ring does not show up with the percentage.  

 

So this started when the battery was around 31%. So on a whim while the Tablet was powered on I plugged in the charger and it was charging my tablet. So I was thinking if it's charging then how can the port be bad? Then after the tablet hit 38% charge the USB Disconnected message went away. I have been using the tablet all day without any problems until 10 min ago when the message came back.  However I believe I have anctual theory on what is happening and a possible solution! 

 

(THEORY) The fact that this is happening on many different devices and not just one particular one makes me think this is a software glitch related to the (Protect Battery Option because the problem only started when I enabled the Protect Battery Option and used it for a day then disabled it later. What this option does is only lets your device be charged to 85% to make the battery last longer. After a reboot it will show your device charge all the way to 100% but behind the screnes it's only charging to 85%. Less wear on your battery hence it lasts longer or so goes the theory.  

 

(SOLUTION) When that USB Disconnected message came back Again at Exactly 31% it made me think about enabling battery protect the day before. Guess what??? When I re-enabled the Protect Battery Option again and rebooted the problem went away!!! You can enable this feature by doing the following.

 

Go to Settings --> Device Care --> Battery  --. Click on 3 dots in top right of screen. --> In Settings scroll down and Enable Protect Battery! --> Restart Phone or Tablet for it to take effect.   

 

If this works for you please report your findings.... Note this options is not available on all devices. Example being my Note 8 does not have it but my Tab S6 does. But then again I never had the problem on my Note 8.  If the Battery Protect feature is actually causing this error like in my case it seems Samsung could fix the problem with an update?

Hi guys try restarting your phone. Not shutdown but restart. Doing this worked on my a20
This solution worked for me! Thank you!

hi, did this method is doing fine until now?

Yes it id working for some devices 

 

a70 problem usb connector disconnected

 "Settings> Apps> Show System Apps> USBSettings> Storage> Clear Cache then Clear data then restart." 
^^^  This worked for me too on my Galaxy S9! Thanks!

 

 

I managed to resolve mine by turning my phone off and using a wireless charging pad. Not had the issue since

First Poster

I have also had this issue with my S9.

I took it to the Samsing shop and they plugged it into the diagnositic tool and said that the charging port was damaged. They re-flashed the software just in case and I got the charging port replaced. Now, less than 2 days later the issue has returned.

It is not a hardware issue, it has to be software.

The restore doesn't work - I've tried that.
Top Liked Authors