Open search

Smart lock not working!


Please fix this samsung. It is PATHETIC  

I have to unlock my phone constantly when I'm home. I've set many safe locations where my phone should be unlocked, yet this rubbish feature doesn't work. 

I've reset cache, data, cleared all safe spots, started again, nothing doing. Useless .. 



Thanks for the great info! This finally fixed my Smart Lock error!!!! My issue was another device on the service. It's so wonderful to finally have this working. Thanks so much!


I looked at my photo history and for sure, the photos taken at home have locations pinned that are over 1/2 a mile away in one instance...


tried that, numerous times but sadly the location in the EXIF tag is correct.



I think I may have finally sorted it...

I had the smart lock fail to unlock just recently so I went into smart lock in settings and selected trusted places. The location shown in the screenshot below is where my Note 9 thought I was. I'm actually in Glasgow, Scotland.

TBF, the phone had only just booted up.


The location below translates to latitude 0' longitude 0'. Now there's a thing!


I've added this location as a trusted place on the basis that it's safe enough to do so, as the likelihood of my phone finding its way to the middle of the ocean off the coast of Ghana is pretty low risk! :winking-face:


Since then, so far, smart lock seems to be behaving itself.

Fingers crossed!

Screenshot_20190225-140329_Google Play services.jpg



I have this exact same issue. In order to get it working again first thing in the morning, I have to repeat the step of dragging the pins around.  So incredibly stupid. I don't understand this "four hours of inactivity" thing. Why is that even a feature? It seems to be causing the entire problem.


I'm updating my experience with the Smart Lock fix. After this post, each fix only lasted 1 hour or 1 day. I finally worked my way through to the final option of clearing Google play services. After restarting, I received a pop-up message that Smart Lock had been turned on. That's actually the first time I've received a message like that. It's been 7 days and it has continued to work.

I still find it annoying that I'm forced to lock my phone and that Smart Lock makes us manually unlock it after 4 hours of inactivity. Why? If it hasn't moved, then I must still be in my trusted place. I just hate it when I spend a great deal of money and it forces me to setup something I don't want, even if it might be a safer thing to do; it should be my choice. But, I'm glad it's finally working... fingers crossed.


What do you mean by "clearing Google Play services"? Desperate to try...

NOTE! I've spoken to Samsung support regarding this issue TWICE! The first time we cleared all my connection settings and this made SmartLock work for a day.

The next time I called they said it was a Google app and asked me to call them. I did and Google said that since it was on a Samsung phone I need to call Samsung 🙄. FRUSTRATING!

Doesn't work for me. Not in Pie, not in Oreo. Even after a clean factory reset with no data restore. 

Top Liked Authors