Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Smart lock not working!

(Topic created on: 28/10/18 18:12)
Explorer
Options
Galaxy S9 | S9+

Please fix this samsung. It is PATHETIC  

I have to unlock my phone constantly when I'm home. I've set many safe locations where my phone should be unlocked, yet this rubbish feature doesn't work. 

I've reset cache, data, cleared all safe spots, started again, nothing doing. Useless .. 

REALLY ANNOYING!  

94 REPLIES 94
New Member
Options
Galaxy S9 | S9+

Brand new j3 and Smart Lock doesn't work for me either.  Have tried everything.

Apprentice
Options
Galaxy S9 | S9+

What everyone forgets, is that if you have added a work email account it will likely have the permission of "Device Administrator", which means your work policy will OVERRIDE all and every lock setting on your device according to your work policy.

Android doesn't show this in it's settings, which can be very confusing.
There is no workaround.
This is often the reason why Smart lock, for trusted location, trusted device, or trusted face, does NOT work as expected.

Apprentice
Options
Galaxy S9 | S9+

Removing my work email and restarting, worked like a charm. That is interesting issue. Thanks for the heads up, I never would have guessed that one.

Apprentice
Options
Galaxy S9 | S9+

Great that it worked for you. It sucks though, not to have your work email. But maybe you still can access it through Webmail in the browser, where hopefully it won't require Device Administrator permission.

Apprentice
Options
Galaxy S9 | S9+

Ya, I will use webmail. I'd rather have smart lock working. Seems like something samsung or google could fix but it's great to finally have a fix for that kooky problem.

0 Likes
Reply
Explorer
Options
Galaxy S9 | S9+

Nope, no work email address here, that is not it. Nobody knows why this does not work properly. I wonder if it is only on Samsung or all Android devices, perhaps the other have the same problem.

Apprentice
Options
Galaxy S9 | S9+

Fixed mine by changing Location setting from High Accuracy to Phone GPS Only. Think it gets false data from local wireless routers. Mine works perfect now.

New Member
Options
Galaxy S9 | S9+

my phone is new few months old, now  now recognizing my home, car or other locations, I h as very to use finger scan, I thought it was me, but I see this is problematic issue with m as my people.

0 Likes
Reply
First Poster
Options
Galaxy S9 | S9+

I was having the same issues until I found this: https://www.guidingtech.com/smart-lock-android-not-working/ . The first step solved it - manually dragging the location pin in google maps instead of using my maps-registered home location. Once I did this it worked. You'll know you've done it right if you have latitude & longitude showing in the location. 

First Poster
Options
Galaxy S9 | S9+
Try the instructions here: https://www.guidingtech.com/smart-lock-android-not-working/ . Manually dragging the location pin in Google Maps , instead of using my home address worked for me.