Open search

Smart lock not working!

But of course this is not a real fix, but just a very inconvenient workaround, kind of like having to restart the computer each time a Windows module stops functioning. Sad that Samsung and Android won't fix this. Oh wait, maybe you have to shell out 1100 bucks for the new S20 to 'fix' it!
First Poster

Look at the post I made about the trust agents. This is fixed it for me anytime that I had an issue.

First Poster

Same issue here - had it far a long time with S8 (though it worked initially) and just upgraded to Note 10 Lite - no issues for 4 days and now for no particular reason I can see, it doesn't work any more.

I have smartlock for front of house, back of house (99% overlap but there it is) , near my bluetooth headset, near my laptop - and I still have to enter my pattern. 

Turning trusted agents off, rebooting and on again doesn't work for me.

Any ideas?

New Member

Biker74 Explorer ... denying that others are having problems is not helpful.  I found this thread while googling why the Smart Lock feature of my S10+ was also not working and I suspect I'm one of the "thousands".  I found your reply annoyingly useless and taking up thread space.


I fixed my issue by following later useful replies of actually turning off Bluetooth and Wi-Fi Scanning.  None of the other options worked. 


Now I'm going to re-install Samsung Pay as I like that app and it seems to be to be a dumb solution to remove one  Samsung app to get another Samsung app working.


If you're not going to post something useful, then please just don't post.

Top Liked Authors