Open search



Is any one else having SD card error on the S9 or S9+ I have a 128gb sandisk and 128gb Samsung and both I have the same issue it starts happening when I used the camera I get a message saying it detected an SD card and is now using it for storage or something along they lines now I have a rewrite issue it goes away if I restart my phone but it cames back again sometime laterScreenshot_20180317-072318_Facebook.jpg




400 REPLIES 400

A reply from Samsung support. ..

They are not aware of this fault and are unable to verify it...  REALLY!!!! 


With regards to your concern, please be advised that we are not yet able to verify this specific issue regarding the SD card error on S9 devices, I can assure you that we will look into this and our engineers will release necessary updates if needed, as soon as we can to rectify the issue, once we are able to verify this problem, we want to thank you for letting us know about this issue.


To receive the latest update as soon as it becomes available please make sure that your device is set to automatic update:


1. Go to Applications.
2. Tap on Settings.
3. Tap on Software update. 
4. Tick on Download updates automatically.


Additionally, please be advised that you can also raised your concern, suggestion, any error or glitch that you may encounter, to our software engineers and software developers. To send software feedback straight to our developers and engineers, please use the Samsung Members application. If it's not built in on your device, you may download it from Google Playstore. To be able to send feedback on Samsung Members, please open the application, select Support and tap on Send Feedback. This will allow you to ask a question or send an error report, in order for our software engineers to quickly resolve the issue. Here at Samsung, we take customer feedback very seriously and we will ensure that your feedback is forwarded to the appropriate team 
for further analysis.

I have exactly the same problem. I used this Sandisk SD card in my s7 ~ upgraded to s9+ ...and this annoying readwrite error occured message pops up every now and then. Now I have to worry about my date on the sd card. Tomorrow I'll save all date from it and try format it ~
Looking forward to hear your experience too.

ImIon my 3rd device and still the same problem.


Hi guys , it's a fail... 

Formatting to Fat32 doesn't work/do anything. I copied 2 music albums and 2 films, took a bunch of photos, all were ok, didn't lose anything. 48 hours later everything still ok, I then dumped more films , albums/playlists , spent 10 minutes in the garden taking a bunch of photos, moved some apps. .... 

Hey presto , card crashed.. 

Back to the drawing board.. !

New Member

I have the same issue, converting from an S8+ with a 128 GB Sandisk Ultra card. I have also tried to backup my data with a computer, but it won't do a clean backup. It starts to copy the files, then it all frees, and it won't respond. I have to unplug the SD-card reader and reinsert it again. I've tried to use a recovery software, and this also stops in the middle of the process of checking the SD-card. I can see all my files but can't get a copy of them out of the card. Please help!


I recently tried to back up my files from the SD to my computer and it stops after only copying a few files.

I can't see my pictures in a computer but can see them on my phone. Basically, I don't have a way of getting my files off my SD card. Can't even upload them to the cloud, it fails.

I'm having the same problem. Whenever I try to copy or upload my photos off the SD card it fails early on. I have a friend who lost all her pics from Disney World because of this.

For months I had problems with my SD card, a 128 GB SanDisk Ultra PLUS.  My phone would say that it card had errors.  I would put it into my computer and it said it was fine.  I would put it back into my phone and it would work for a day or two then show errors.  Finally it became so corrupt that the phone would say that there was not a SD card installed.  I put it into my computer and it would stop communicating or the equivalent of what some has said freezing up.  I put the card into my computer and ran a chkdsk/r/f command.  It got the SD card to where I could copy the files to my computer.  I then copied the files to a 64 GB card and installed that card to my phone.  It has been working without any errors for 5 days.  Here is a link that will explain how to run chkdsk.  It take a while to run!  Don't stop it until it finishes.


I've now downgraded to a 64gb card with NO issues at all, everything is fine. .

One thing I have noticed, everyone is having problems with 128gb cards -Samsung and Sandisk.. Anyone having problems with smaller cards? Could it be that the S9/+ cannot read/unable to use 128gb cards? Anyone using 256gb?

Any job vacancies at Samsung Tech?
Some of us have done a better job than them!! 😂🤣😁🤣
Top Liked Authors