Open search



Is any one else having SD card error on the S9 or S9+ I have a 128gb sandisk and 128gb Samsung and both I have the same issue it starts happening when I used the camera I get a message saying it detected an SD card and is now using it for storage or something along they lines now I have a rewrite issue it goes away if I restart my phone but it cames back again sometime laterScreenshot_20180317-072318_Facebook.jpg




400 REPLIES 400

Persistence is needed. ~300 or so photos, taken in quick session, combined with swiping away the camera app out of memory and going back in. I am up to phone #3 with the identical issue and I have learnt to live with it. All photos go to the phone until I decide to move them to SD. 


I posted a month or so ago and in the last few days the problem has gotten much worse.  Up until now, I hadn't beem motivated to deal with it.  Last night, I took the SD card out and put it in my laptop's reader.  I then took another 128gb card from my tablet (samsung branded card) and put it in my s9+ and formatted it.  I then plugged the phone into the computer and started trying to move the files.  It went for a few minutes and then stalled.  I reformatted the card in the phone and unplugged it.  I decided then to try to drag the files from the old card to the computer and then try to move them to the new card.  That stalled out as well.  I ran the drive repair utility on the card.  It said it fixed some card errors.  So, I again tried to move the files from the card to the computer.  Still stalled out.  I had to go to bed after that, so I haven't done any more.  I read a suggestion in another forum recommending that I set up my computer to dual-boot Linux and try to do the file transfer in Linux, as it may work better than with Windows.  I might have time to try that this weekend and will report back with results.  Thoughts?  Discussion?  Snide remarks?


I am not sure if this has been mentioned yet...but...this trick seems to have worked for me. I did this about 4 weeks ago and have not had the pop up since.

Here is what i did....
1) power down the phone.
2) remove the SD card tray from the phone and remove the SD card.
3) Reinsert the SD card tray with no SD card into the phone.
4) power up the phone.
5) open google photos or any other apps you think may be causing issues. let the phone run for a little bit.
6) power down the phone
7) remove the SD card tray from the phone and insert the SD card back onto the SD card tray.
😎 Reinsert the SD card tray with the SD card into the phone.
9) power up the phone.
10) come back to this thread and thank me. 🙂


This does NOT work. The error comes back after some time.


Corrected spelling..

You are correct!  There have been too many cards tried and they had problems.  Wish I had my Samsung S7 edge back.  I had no problems with it.  Have had Icon notification number problems with this phone and it is finally resolved, but now get SD card errors many times a day.  I worked in a manufacturing facility in marketing for 41 years and the customer was always right unless I could show him where he was wrong.  Samsung has not done that they only put the blame on every SD card manufacturer out there.  Samsung needs to take responsibility and fix this problem we are having with their $900.00 phone!  The SD card that I am using is one that Samsung gave me when I bought my S7 edge and never used it until I got the S9 because I already had a 64 GB in the S7.  So the SD card I am having a problem with is one that was sent to me by Samsung.  The S7 and a SanDisk 128 GB was a bundle deal at the time I purchased the S7 EDGE.


I know this isn't going to be very helpful or what people want to hear and may not apply to those of you who purchased new cards. 


I was having an issue with a SanDisk Ultra Plus 128GB micros XC1 card after I received my new S9+. I used this card in my S7 with no issues. I can still use it in my S7 without any errors. I primarily use the card for photo storage, video storage, and I do a bunch of large video file downloading and deleting, upwards to 2GB.


I started getting this error on day one of owning the S9+. My son gorbhis S9+ the same day and has a 64GB card in his. He has never seen any error messages regarding the card. 


I decided to check out the card using a software tool I have to recover lost or deleted data on SD cards. As soon as I popped it into the PC, it wanted to check the card for errors. I skipped it and started backing up all my files on the card to the PC. Well I discovered that I had several files that were corrupt and no longer accessible and my file copy process was taking forever or would hang because of it. Come to find out my card is so jacked up that it can't even be formatted. I have attempted to delete all the files from the card with no success and tried a few different ways to wipe the card. 


I happened to have the exact same card that I used in my old Windows Surface 3 that I now use in my phone. I plugged it into my phone, performed a format on it from the phone, and have not had a single issue. It has been about 2 weeks now. I still create videos and pictures and transfer large files back and forth from the device and card.


As far as the other SD card. I'm still playing with it, trying to get it formatted. 


Again, I know there are some of you who have bought brand new cards so this may not apply, but try running some checks on the cards with a PC to see if there are any bad sectors on it. 

First Poster

I too was plagued by this error message immedialy after upgrading my S5 to a new S9.


I had my previous 64G SD for about a year.  Not a single issue in my S5.   Moved it to my S9 and everything seemed fine for week or so.  Then the errors started on and off for a few days.   Eventually they became a daily occurance.


I've read all the complaints and I agree buying a new phone and immediatly having issue with your SD card is annoying. Escpecially if you have been error free for a long long time.


I removed my 64G SD and placed it into my PC to copy all of the files to the harddrive.   Low and behold there are errors on the SD card that were not present when the card was in my S5.   The errors became apaprent when I could not transfer some pictures and files from the drive.   I copied off all I could by excluding those erronious files and I replaced the SD card with a new 64G SD card and the issues have gone.   Same manufacturer, same size, DIFFERENT specifications.


Now for something I have not seen in another post yet.... Then again I have not read ALL the SD error posts...


When replacing my 64G SD card there are difference Classes and different U ratings...  My old SD card was a Class 10 card but it did not have a U rating, so I am assuming U1.    The new card I purchased is a Class 10 with U3 rating.


U1 means that it is guaranteed to transfer at a minimum of 10 MB/s whereas U3 it's guaranteed to transfer at a minimum of 30 MB/s.


The new S9+ camera can record 4K UHD video and that requires a minimum of a 30MB/s transfer rate according to Sandisk.


I wonder  if our older trouble free cards get corrupted by the OS constantly driving all read/writes, not just the video capture, at the 30MB/s?


Would be interesting to hear if everyone who is having the SD card error issues has purchased a U3 or higher SD card.    Wondering if Samsung has SD card specification that needs to be notated for U3 for the S9+.






I did a check disk using my PC and that was OK; however, I did let it go ahead and do a check and repair.  I ran Malwarebytes and checked close to 8,000 items for malware and it did not give any SD errors.  The card I am using is a U1 type; however, I do not do any video recording so I would not think that it should cause a problem.  With so many people having a problem Samsung needs to specify that a U3 is needed, if that is the case.  I did not find this on the specifications of the S9 or S9 Plus.

First Poster

This is PATHETIC. Coming from an Apple fan boy to finally try out the best android phone and top competitor ... this is just horrible.


I was on my trip to Universal Studios taking many pics and when I switched to try and record 4K 60FPS thats when I started noticing issues. Maybe my card could not keep up because the camera app was so laggy when it was stopped recording (to save the large file to the memory stick). Now I get corrupted memory stick and my PC does not even read it. (SanDisk Extreme 64GB U3 MicroSD XC I)


This is F*I** \SHS** *. F* U* Samsung! I will never buy another samsung galaxy or android ever again. .


I am so p***** because I expected so much more from you and now i find out so many other people have the same memory stick problem. This phone is so unreliabble and the rest of you guys who have never tried an apple iphone and think that it is a bad phone need to get ur head out of your A** and start paying for what you get.


Cant wait to leave this ... I am just LUCKY that i had google photos on and my photos saved online. This is pure LUCK that universal studios had wifi.


Never Samsung Agian. Samsung please contact me to make things better.

@hen555 This is not a marketing forum, this is a support forum so please try to focus on the issue instead of marketing and promoting Apple products.

I have the same issue on mine. Not all the time, but it comes now and then. Multiple branded SD cards, including Samsung Evo cards, and SanDisk extreme cards. Doesn't matter if it's a cheaper slower card or super fast SD either. The error pops up. No issues with anything else using the card on the phone. Sometimes I'll notice pictures I took are in internal memory instead of the SD card, meaning it's not recognized for a while. Came from an s8, using the same card and no issues.. 

Top Liked Authors