!-- End Google Optimize -->

Open search



Is any one else having SD card error on the S9 or S9+ I have a 128gb sandisk and 128gb Samsung and both I have the same issue it starts happening when I used the camera I get a message saying it detected an SD card and is now using it for storage or something along they lines now I have a rewrite issue it goes away if I restart my phone but it cames back again sometime laterScreenshot_20180317-072318_Facebook.jpg




400 REPLIES 400
I am on the Samsung chat line about this very problem and they seem oblivious to it despite all of us having the same issues.....poor in my mind

Samsung support Is the worst. Most of the issues people are having like the SD card issue and the BLACK CRUSH and dropped calls can all be solved with a software update but samsung aren't listening to us at all, I've bought a new SD card which is arriving tomorrow if it doesn't fix this problem I'm going to repair centre and getting it fixed. Am I best of formatting the SD in my phone before 1st used or in a pc some say the s9 supports Exfat and not fat32 so guessing s9 format will set it to the correct one. I wouldn't mind all the issues im having if samsung spoke up and said this is what we are going to do to fix but it's been weeks and weeks and they've not given us a straight answer.


I am having the same (read/write) error.

At the same time, it does not affect the function of the card or the phone.

The data are read or written correctly.


Any update?


My Sandisk has corrupt twice so I've purchased a Samsung Evo Plus 256GB card and so far no errors or camera pop up saying sd inserted. I formatted the brand new card with my s9 plus when I first inserted it and I think it's put it in the right format which is EXFAT not FAT32 

First Poster

I just got my 64gb s9+ on the 23rd, and I've been having this same issue from day one. I read through the entire thread hoping to come across a valid solution, or at the very least, confirmation that Samsung is working on the issue. Oh well.


Same problem here on the s9 64gb U.S unlocked.. i bought 3 different 128gb microsd and all have the same issue.. same read/write errors and after a while i start losing data or things go corrupt.. ughh 


I've been having the same issues on my new s9.  I have a128gb memory card that had no issues at all in my s7. A few days after putting it into my s9 I've been getting a read write error. No data lost that I've noticed and I tend to get the error while web browsing rather than anything else. A reboot of the phone sorts it out for a while. Can leave the phone in my pocket all day with no issues, it's only when I'm actively using it. 


Uk based, 64gb S9 locked to vodafone.


I am not sure if this has been mentioned yet...but...this trick seems to have worked for me. I did this about 4 weeks ago and have not had the pop up since.

Here is what i did....
1) power down the phone.
2) remove the SD card tray from the phone and remove the SD card.
3) Reinsert the SD card tray with no SD card into the phone.
4) power up the phone.
5) open google photos or any other apps you think may be causing issues. let the phone run for a little bit.
6) power down the phone
7) remove the SD card tray from the phone and insert the SD card back onto the SD card tray.
😎 Reinsert the SD card tray with the SD card into the phone.
9) power up the phone.
10) come back to this thread and thank me. 🙂



This has happened repeatedly since I purchased my new Galaxy9 phone in April 2018. Very annoying 


I exchanged my s9+ for another one.  My new phone has not experienced any SD card issues at all.  It was clearly a faulty phone.

Top Liked Authors