Open search



Is any one else having SD card error on the S9 or S9+ I have a 128gb sandisk and 128gb Samsung and both I have the same issue it starts happening when I used the camera I get a message saying it detected an SD card and is now using it for storage or something along they lines now I have a rewrite issue it goes away if I restart my phone but it cames back again sometime laterScreenshot_20180317-072318_Facebook.jpg




400 REPLIES 400
First Poster

Having the same issue. SD card read error keeps popping up but I can still take pictures to it and access files on it. Idk what the problem is.. Might have to reformat the card but that would include removing everything from it, reformat, and put it back. Tired of delaying the error every 2 hours. Cmon Samsung. 


I have tryed reformating the issue came back hours later i also tryed another SD card that I got with the phone but I still get that error  i can still use my sd card but it's just anoying 


Having same issue





I am also having the same problem i cannot transfer my files to the phone memory either this is annoying 😤


I don't get the SD card error but every time launch camera it tells me SD card is inserted and being used as default storage this pop us is annoying.


I get the same error with a 126gb Sandisk card. It's the same card I used in my S7, I just moved it straight from the old phone to the new one. 


Going to try transferring data to PC, formatting card and then putting it back into the S9+

If all goes well, I'll put everything back on the card. I have noticed there are a lot of android data files on there - these must be from apps which used the storage on the S7 (I think). So I've just deleted them. S9+ has not complained (yet) that they are missing. 


If all goes well I'll report back....


Look forward to hearing back to resolve this issue sometimes i hear even formatting memory card brings up the message so hopefully this issue can get resolved quickly.

This is how mines started then the more I used the camera I started getting readwrite errors
Have you tryed clearing system cache I did it yesterday morning and so far the readwrite error hasn't came back plus that annoying popup when using the camera has also gone
Top Liked Authors