Support

Open search

screen problem - washed out color and black crush grain with some horizontal faded lines

Highlighted
First Poster

Samsung S9 started to have screen problems a few weeks ago, after doing several official updates. this happened just before the 2 year guarantee expired (coincidence?). because of the pandemic I couldnt go to the samsung store and action on the guarantee. have  factory reset, and clean up cache and still a problem. 

 

does anyone have a solution or faced the same problem?

 

thanks

12 REPLIES 12
Highlighted
Voyager

 

hi @guiribeiro 

 

since you're with the troubelshooting tests 

 

please contact your Samsung Support to discuss the repair options 

 

thanks ☺

 

Highlighted

Hi, thanks for your reply. I did indeed try to contact support but because of the pandemic I cannot get through. Is there any mod that can help perhaps?

Highlighted

 

from what country are you at? 

Highlighted
Uk
Highlighted

@guiribeiro 


you may reach them through live chat or phone:

 

Live chat link:

 

https://www.samsung.com/uk/support/livechat/

 

Phone: 0333 000 0333 (UK) or 0818 717 100 (EIRE)

 

thanks ☺

Highlighted
First Poster

is this resolved ?? i am also facing similar issue

Highlighted

facing the same issue in my s9 plus after june 2020 update. any solutions???

Highlighted
New Member

Same issue with my Galaxy S9+. Thought it might be software, because sometime the screen will unlock and look ok, then after a few seconds, it goes back to the washed out color mode. I played with all the settings, went as far as performing a factory reset, and it didn't help. 

You can play with the brightness controls and when really low, it looks ok, then 1/4 way up is the worst, where it is yellowish and dark with visible horizontal lines, like  every 3rd pixel row has no color.  When you max the brightness it becomes usable, but the color is still not right, and really not a useful work around, (battery, eye strain etc.)

Maybe something is loose inside the phone? 

Highlighted
New Member

Go to Settings>Wallpaper and disable "Apply Dark Mode to Wallpaper". That fixed it for me. Let me know if it works.

Top Liked Authors