Open search

S9 wifi internet may not be available.


I have two s9 phones both over last few days since a samsung update on 8th April are coming up an exclamation mark when connecting to my wifi saying internet not available. This happens when it switches between my 2g and 5g ssids. The phones are indeed connected to my wifi as when turning off mobile data and connected to wifi I still get web pages. Although with this error can't download from Google play or connect to anything on my lan.

The issue goes away if I turn off 5g ssid on my router not ideal!! Router has latest firmware and all other devices connect fine as well as an old htc m8 phone no issues only on two s9 phones do I get this anyone any ideas.same issue here although on s8

First Poster

Same issue here too. I'm in the US with the snapdragon varient. I'm not sure if the exynos varient has the same wifi radio as mine, but the symptoms are exactly the same. I've tried wiping cache partition, and forgetting the network and resetting the network settings. Or just turning off and on wifi. That works for a time, but the issue always returns at some point. I've come to believe that the wifi hangs when my router switches it from 2.4 to 5 ghz. I hope Samsung can fix this quite annoying bug. 

Are you using Singtel router ? If yes, change to other brand of router will solve your wifi issue. I have tested with Asus and Linksys router, no wifi issue.

Singtel refer me to Samsung too, as my warranty is over, Samsung need to charge $32+ for evaluation of the phone. I assume they will reset my phone to test which I have done so factory reset and same issue. Or ask me to pay for a new wifi hardware etc. But I change to other brand of router solve the wifi disconnect issue.
New Member

Same issue here as well. I've tried pretty much everything but there are a few more ideas listed here that I'll try next time I need WiFi. 

I have the same problem with my s9. I don't even see 5G SSID on my wifi list, let alone try to connect it. My software info is Android 8.0.0
Samsung Experience version 9.0

android secruity patch level 1 may 2018

@Oscar_Asian wrote:

I have the same problem with my s9. I don't even see 5G SSID on my wifi list, let alone try to connect it. My software info is Android 8.0.0
Samsung Experience version 9.0

android secruity patch level 1 may 2018

What is your router ssid? Did you set to turn off your router auto steering function? 


heck.. kept thinking it was something I. Changed my wifi back to 2 instead of 5 and sure enough everything worked again - what the heck? Thanks again for the share


First Poster

Hi Guys,


Having same issue with S9+. So fro what iu can see the issue technically is not related to 2.4ghz or 5ghz, or at least not in my instance. What i have found is that any network that consists of more than one AP, with the same SSID, causes issues. It seems Android does not like the handover between devices with the sams SSID but differing MAC addresses. If i even use the same devices as the work network but set them up that each AP broadcasts a different MAC address, it works perfectly. The minute it is one unified network, multiple AP's with one SSID, it causes issues. This is a major issue with people who use their mobile devices for work purposes. Laptops, desktops and Apple devices have no issue with this configuration. I never had this issue with my S6.

First Poster

This simply due to conflict on using IP address between two devices. You only need to change the generated ip to another end.

For example if it is



Only last digit

It will work. 


First Poster

Having this exact problem. I just bought and S9 for both my wife and I and have them connecting to a TP-link EAP245 which is serving the same SSID on the 2.4GHz and 5GHz bands. The EAP245 is then wired to a router running Tomato. My wife's phone has a static IP configured and she has never complained. My phone's IP is still dynamic and it randomly does this. Especially when I go to the basement where it is likely to switch from 5GHz to 2.4GHz. I have to turn the Wifi off and back on for it to work again.


I've just set my S9 to also use a static IP. Hoping this fixes it, but you know I really shouldn't have to. My old S5 and S7 both work perfectly. Samsung, get your s**t together.

Top Liked Authors