Open search

S9 + Swipe to type not working and auto spellcheck gone crazy and no predictive text.


Well my S9 + is finally here after moving from S7 edge.


The only niggle so far is the keyboard. All options are turned on and the correct keyboard is selected.Swipe to type when active gives me the blue lines when i drag over the keys but nothing inputs on any app.


Quite frustrating as this is my primary way to type.


Also the spell check is putting the red line under normal words and only suggesting an email address as an alternative or the word mart for some reason.


Predicive text is non existant apart from the word mart and sometimes email addresses.


Any input would be great.

Solved my issue with g keyboard. Samsung update on 1 Oct 2018 broke default keyboard badly
New Member

Bring up the keyboard through the text app, hit the settings button, go to smart typing, at the bottom there is a selection for swipe controls. That is what worked for me. Hope that helps. 



I tried the steps, but the last step, I received a notice that it might increase the cost of my plan.  Did this happen to you?


I have tried the Google keyboard and yes it works but calls everyone I text.  There is no update listed for the Samsung keyboard for me.

I was skeptical at first, thought it was too good to be true let alone so simple, but I sure am glad I checked and tried your solution. I was not a fan of the gb. Thanks-a-million!
Thank you so much for help.. I just want to Add with your post that if the settings of predictive text is on then just off it and on it once. Ur problem will be solved


Followed your instructions to the letter and it cured my problem and also the fact that predictive wasn't working either. HOWEVER it only works if I choose English(US) it still does not work with English(UK) and since we invented the language (English being a bit of a clue) it's pretty annoying.



thank you.this helped alog

Top Liked Authors