Support

Open search

S9+ no missed call alerts

Highlighted
Explorer

Hi I’m having issues with no missed call alerts the only way to solve it seems to be to turn off caller Id and spam protection as was advised on Xda forums it seems there are many others with this problem anyone know any other work around as that feature is important to me?

 

And obviously getting no missed call alerts is not an option I’ve already missed some important calls!!

 

S9 plus single sim tried factory reset wipe cache etc still the same really not happy about it to be honest and I didn’t expect this after spending this much on a flagship 

 

Thanks 

55 REPLIES 55
Highlighted

Likewise doesn’t work for me only way is still to turn off caller Id and spam protection.

 

This is supposedly being fixed but can’t see what’s taking so long 

Highlighted
Apprentice

I just got my s9 plus and don't like that I don't get a missed call notification. What happen to that feature? If there is a voicemail it will show me on my lock screen but nothing about a missed call unless I check the calls myself

Highlighted

Have done what you suggested will see if it works

Highlighted

Thanks for sharing Lolarguez this worked for me  and can still keep my spam blocker on

Highlighted

Was able to fix. 

Did this and works

 

Go to settings->Notification->Advanced settings->Advanced notification settings->contacts 

 

And am still able to keep the spam block on

Hope this is if help to everyone this was from LOLARGUEZ posting in this forum

Thanks but doesn’t work for me still same issue. It may work for you but I’m sure once you restart the phone it will stop again. Only way for permanent fix is to switch off spam protection 

Highlighted

this one worked for me so far.

 

Highlighted

Just got my new S9 and this was the first problem I encountered. Seems its an ongoing problem.

Any offical news from Samsung about it?

Highlighted

Just an update to my solution that I provided from someone else, my phone has been restarted several times since I have done this and I still get my notifications seems to be all good so far.  :smiling-face: 

Highlighted

This worked for me thanks :smiling-face: 

I have now posted in my thread in hopes it will help others 

Top Liked Authors