Support

Open search

No 4G connection (symbol shows!)

Highlighted
New Member

Hi,

 

I have a Galaxy S9 since 1y and it worked fine. Recently I updated the software to the latest version, and I noticed my 4G doesn't work. The symbol shows, but only the arrow UP is constantly lit. The DOWN arrow is blank. I contacted my provider and they saw no problem. They have given me a new SIM-card, without any result. When I put this SIM-card in an old S6 device, the 4G connection works fine. So I think the problem is with my S9 device. Maybe it has nothing to do with the update, but I think this in not a coincidence.

Anyone has this problem too?

 

Solution?

 

Kind regards

Jari

14 REPLIES 14
Highlighted
Moderator
Moderator
Hi jari8289

Can you check if 4G is enabled, sometimes the Software update can reset some settings:

1. From the home screen swipe either up or down to access apps.
2. Tap Settings.
3. Tap Connections.
4. Tap Mobile networks.
5. Tap Network mode.
6. Tap LTE/3G/2G (auto connect).

Also, does the 4G connection not work in any area or is the problem only in certain areas?
Highlighted

I have no 4G symbol either on my S9. 

The settings is on 4G.

But if I turn of wifi the 4G or 4G+ symbol comes up.

So I think the S9 prioritaise using wifi and when wifi is not availible S9 goes over to 4G.

Highlighted
First Poster

I have the exact same problem (4G arrow up, sim swapped, no solution). Also did an update recently. I contacted my provider (Proximus Belgium) and they said this is known issue at Samsung. I have changed the settings to only connect through 3G/2G and that works. Don't forget to reboot after you've changed the setting.

Highlighted
Btw: it would be nice if someone from Samsung could confirm it this is indeed a known issue.
Highlighted

Here, in Belgium, the same problem. After the update: no 4G anymore. Changing the settings in 3G/2G works, but that isn't a solid solution. Hello, Samsung? A reaction please! We want 4G back!

Highlighted
First Poster

I can confirm the 4G works again with the latest update from August 1. G965FXXU6CSGD

Highlighted
I felt the same issue of having LTE connection problem, although the area have strong 4G network. If i turned on the data of my S9, first it shows 3G connection i.e. H or H+ and takes time to connect to a 4G network and show LTE. Yes, the problem started after a certain update released from Samsung. I found somewhere that S9 model SM-G9600/DS is facing this problem which I possess. Could others plz check if there models are same or different?
No solution yet?
Highlighted
New Member

Hi

I have the exact same problem since the update in december. 

*Galaxy s9

*4g not working 

*Up-arrow lit

*3g works

 

Did a network reset, which solved the problem teporarily, but the issue is back and not even a reset can fix it now.

 

Hello Samsung! This is a pretty serious issue. Fix please.

Highlighted

Hey guys, glad to learn I'm not alone, upset to find out there is no solution 

 

Got my fresh sexy S10e in December 2019, I bought it in Mother Russia. Nothing even remotely close to the issue in question. As soon as I turned Wifi off - I get connection whatever my phone can receive, including 4G. All was great, even though the network that I use in Russia (called "YOTA") is known to have mediocre to poor coverage. 

 

Came back to the UK and, as usual, wherever I go - the Internet connection is utter garbage (no matter the number of bars your cellular/wifi symbol displays). 

 

I started experiencing the problem right after I came back to London. For me it works like this: after using WiFi, when I need to leave the location - I turn WiFi off and LTE does not pick up. In fact, nothing does. I simply get the network bars without any Internet symbol and, obviously, without any internet. I tried airplane mode, restarting (2-3 times in a row won't help), fiddling with settings. Only now I tried downgrading to 3G and it is working as good as 3G would. 

 

I do blame the network (giffgaff) as I never experienced the problem with a Russian network, however I also need to note that that never happened when I was using my iPhone 7. 

 

 

Gonna contact both Samsung and the network tomorrow. 

 

Peace. 

Top Liked Authors