Support

Open search

How to Turn Off Screen Wake From Text Message

Highlighted
SOLVED
Apprentice

My problem with my new Samsung Galaxy S9+ is that with the stock Messages app that comes on the phone, how do I turn off the SCREEN WAKE feature that is automatically set on the phone for Text Messages??? I do not have a problem with the text preview and the notification icon being placed on the Always On display, but what I do not like/want is for the screen to automatically wake up for those brief 2-3 seconds when I get a new text message. This ONLY happens from a new text message. Any other app, when I get a notification, the screen stays off, and will just vibrate or play the set sound I have, and will display the notification icon for me to see when I myself turn on the screen. The Messages app is the ONLY app that screen wakes the phone upon an incoming text message and that is annoying. And none of the suggested steps regarding the Always On Display or settings within the Messages app turn off this feature. Is turning it off even possible??? PLEASE HELP

32 REPLIES 32
Highlighted

Thx it works

Highlighted

If you turn off the notification as you write, the person will not receive the notification (icon) on the AoD...

 

Highlighted

Okay so I turned that off, now I don't get the notification on the AOD... Grrr... frustrating!!

What's strange is I had something right and now all of a sudden it wakes up the screen.  I just got this Note10+ last week and I truly miss just the blue LED light that would come on, on the Note 8.  😞

 

All I want to happen is the AOD and beneath it a little messages icon... no lights.. no bells, no vibrate...  when my phone is on silent.

Highlighted

Try this. Head to Apps > Settings > Accessibility > Advanced Features > Flash Notification > Screen Flash > Off. 



 Welcome to the Community! :smileyhappy:

Highlighted

Not working here. Going crazy

Highlighted

Had this issue when my phone changed to android 10. This was a work around 

Inside the messaging app

Settings > notifications > new messages

Make sure "alert" is selected, not silent. If it's silent then it will ALWAYS wake the screen, in my experience.

Also make sure "show as pop up" isn't enabled 

 

Then in Android, go to settings, search for edge lighting, make sure it's enabled. If you don't want to use edge lighting, just make sure all the sliders are off.

 

Voila

Highlighted
First Poster

I never had this problem until the first day I got the S10. It drove me insane and couldnt figure it out. I've tried about every solution in this thread among others (short of root access) with no solution. Yesterday I got the new s20 and what do you know, the same issue. I finally found a fix for me though and the problem is its a combination of a few things. This is what I found that works.

 

The first thing that you NEED to do is go to Settings > Lock Screen > Turn on notifications. Enabling it is the only way it works. If you tap on notifications then you can change to detailed or icon only. I just put mine to icon only. Then the next steps are preference depending on if you either want just edge lighting message notifications or if you would rather have no light.

 

Edge Lighting:

Phone Settings Display Edge Screen > Edge Lighting > Turn On > Choose Apps (Select Messages) > Show Edge Lighting (Select Always or While Screen is off) ... Then go to Messages Settings > Notifications New Messages Lock Screen > You can either select Show Content or Hide Content.

 

No Edge Lighting:

It doesnt matter if you have edge lighting enabled or disabled, just go to Messages Settings > Notifications New Messages Lock Screen > Select "Do not show notifications"

Highlighted

Hello. What about for other apps? Just got the S20 plus and I just noticed that this is happening with my OfferUp alerts. Havent noticed any other so far. Using Texta for texts...

Highlighted

@Luckiethirteen wrote:

Hello. What about for other apps? Just got the S20 plus and I just noticed that this is happening with my OfferUp alerts. Havent noticed any other so far. Using Texta for texts...


I have the s20 ultra and I'm getting the same problem on my Samsung messages app and offerup. When I'm getting a lot of text messages it significantly drains the battery when the wake screen keeps turning on. 

Highlighted

@mmafighter077 wrote:

@Luckiethirteen wrote:

Hello. What about for other apps? Just got the S20 plus and I just noticed that this is happening with my OfferUp alerts. Havent noticed any other so far. Using Texta for texts...


I have the s20 ultra and I'm getting the same problem on my Samsung messages app and offerup. When I'm getting a lot of text messages it significantly drains the battery when the wake screen keeps turning on. 


And none of the solutions on this post have worked for me. 

Top Liked Authors