Support

Open search

How to Turn Off Screen Wake From Text Message

Highlighted
SOLVED
Apprentice

My problem with my new Samsung Galaxy S9+ is that with the stock Messages app that comes on the phone, how do I turn off the SCREEN WAKE feature that is automatically set on the phone for Text Messages??? I do not have a problem with the text preview and the notification icon being placed on the Always On display, but what I do not like/want is for the screen to automatically wake up for those brief 2-3 seconds when I get a new text message. This ONLY happens from a new text message. Any other app, when I get a notification, the screen stays off, and will just vibrate or play the set sound I have, and will display the notification icon for me to see when I myself turn on the screen. The Messages app is the ONLY app that screen wakes the phone upon an incoming text message and that is annoying. And none of the suggested steps regarding the Always On Display or settings within the Messages app turn off this feature. Is turning it off even possible??? PLEASE HELP

32 REPLIES 32
Highlighted
Any solutions to this Samsung messaging app issue waking the screen? I cant believe we are now on an s10 and issue remains.
Highlighted

Brand new s10 there. Very annoying problem. Often my phone is in my pocket and unless it is cold outside it registers touched in my pocket.  so if I get a text message and I don't read it for 30-minutes the screen stays on in my pocket for 30 minutes. It's bull*****. There's tons of reasons we should be able to turn this off

Highlighted
New Member

You need root access so you can edit the config file of the stock Messages app manually. On my Nougat Android, this file is called /data/data/com.samsung.android.messaging/shared_prefs/com.samsung.android.messaging_preferences.xml.

 

There are two lines in that file:

<boolean name="pref_key_backlight" value="true" />
<boolean name="pref_key_backlight_sim2" value="true" />

 

Just change "true" to "false", save, reboot -- and there will be no more annoying screen wake from the stock Samsung Messages app.

Highlighted

Try this. It works for me. Settings-> search for edge screen. And make sure that edge lighting is on.Screenshot_20190621-214601_Edge screen.jpg

 

Highlighted

Still no fix for this? It's doing my head in! May have to Google too Google messager app

Highlighted

@Adibordoy wrote:

Still no fix for this? It's doing my head in! May have to Google too Google messager app


I just use Android messages. It's pretty good. Textra is my second choice. Well worth the paid version

Highlighted

Problem solved

Download edge mask, make sure wake screen is off and then app specific at bottom to messages, click apply. 

Highlighted
Edge mask works better and you can still use stock messaging.
Highlighted

You dont need to download anything. 

Working on my s10

You just need to open Messages >•••>settings>notifications>new messages>lock screen> select dont show notifications...

 

It will vibrate and sound but wont turn on the screen... 

Let me know if it works for u. 

View solution in original post

Highlighted

Yes that method works thank you 

 

👍🏻

Top Liked Authors