Support

Open search

How do I prevent the phone closing my background apps?

Highlighted
First Poster

For example, I play Pokemon Go and use the Go Plus Bluetooth device, therefore I'm able to play it with the app running in the background. However if I open another app, let's say I want to look at Facebook while using the Go Plus to play the game at the same time, within a minute the Plus is disconnected and the Pokemon Go app has been closed. When I go back to the app it has to restart and load up again. Same applies to all apps, Facebook, web browser etc.

How do I stop this happening?

19 REPLIES 19
Highlighted
First Poster

There are only two way:

1. Settings -> Device care -> Battery -> Settings -> Sleeping apps -> Add -> here you need to mark as many applications as you don't need in the background -> Add -> Restart phone

2. Buy a new phone with more RAM.

There is no other way.

Highlighted

This is the best solution... it worked .thanks 

Highlighted
First Poster

I figured it out finally for the s10.  You go into settings of pokemon go.  So go to your phone apps then pokemon go.  Then go to battery.  Then Click optimize battery usage.  You will see That pokemon go is auto optimized.  So even if you change all the other settings and shut off power saving and everything else, the app is still being optimized to not actively run in the background.  So click all apps when on this screen.  And uncheck pokemon go so that it is not automatically optimized.  Now I can finally play pokemon go with my gotcha watch while I have my phone locked and in my pocket

Highlighted
Thank you so much! I think this helped :smiling-face:
Highlighted
Observer

This seems to be an issue with ZTE blade I switched it to safe mode and then switched it back now I can go back and forth between my apps without them closing.. hold the power button down when the menu pops up hold the power off button until it gives you an option to go to safe mode when your phone restarts in safe mode hold the power button down again then restart your phone.. this should work

Highlighted
hi - just got my s9 - ive got all the power/battery save opts off .... but still after a while apps are sent to sleep it seems .... think it must be a core s9/ui thing 😕
Highlighted
Pathfinder

Open the desired app. Enter the multitasking mode (that shows all of the apps opened) and tap the app icon over the window. Select "Lock this app". This will lock the selected app in your RAM, preventing it to close. It will close when you remove it from multitasking or restart your device.

Highlighted

cool thanks - that should keep messages app loaded :smiling-face:  ... didnt even know that feature existed :face-with-tears-of-joy:

Highlighted

This doesn't work for me at all, as well as all of the other suggestions so far. It seems that the only thing that works is to disable device manager all together. I just can not get over how incompetant Samsung is. I thought buying a phone based on an open source OS would stop the all controlling bull***** that Apple does. This is my last Samsung phone, after this I'm moving to cheap Chinese knock-off.

Highlighted

yes true it isnt 100% i find ..... it does better .... but still after a long time the app wont be loaded even though it is still in the app switcher view  .... agree is a shame that sammy went over the top with this ram manager stuff 😞

Top Liked Authors