!-- End Google Optimize -->
Support

Open search

Gmail delay notifications

Highlighted
Apprentice

Hi,

I just bought a S9 last week. When the phone is in my hand and I am using it, I receive gmail notification and email right away, but when I put my phone aside after a couple of minutes not using it the notification/emails will arrive very late. starting from 10 min late until hours late. In additon If i take my phone in my hand and open it all the mail notification will arrive asap. It is as if my phone/gmail goes to sleep/standby mode when I do not use it. I tried everything. Delete data and cache. resept app settings. reset network  settings reset, setting reset. uninstall and install gmail again. I have no battery optimization on for gmail. sync on the phone is on and sync on gmail setting is also on. I tried everything that can be found on the internet but was not able to solve this issue. gmail sync is arriving very late. help would be very much appreciated.

thanks

38 REPLIES 38
Highlighted

its working only when the phone its not in "stand by" mode - in the daytime its work almost 100% with what you write and with other suggestions - but after 6-7 PM when i use the phone less - maybe one time per hour, gmail still not sync as it should..yesterday i receive one email at 20.48 - i didnt receive it until today in the morning :smiling-face:

Highlighted

Can I get clarification on whether changing to the native Samsung email actually ''fixed'' the issue Gargamel?  I'm having the exact same problem, the issue is seemingly random: sometimes emails come in, sometimes not, sometimes I get the icon appear but no sound, sometimes nothing at all.. etc.. if using the Samsung email app works I'm tempted to just use that!  Not ideal but better than missing important emails..

Highlighted

I confirm 1000%..Samsung Email App solve the problem. Since i use it i have no longer problem receiving emails

Highlighted

Uninstall Google APP, and it will fix the problem!

Highlighted

Since this is the top result in google searching for gmail delayed notifications, I found this to fix the problem on my S9 Galaxy. I didn't come up with it, found it on a different forum. This does not require the phone to be rooted.

 

Basically this disables some form of deep sleep in the phone. I haven't found it affected battery life much, if at all, but I am sure that's why this feature exists.

 

Also, this will only disable the deep sleep feature until the phone reboots. At that time it will return or normal and you would have to re-run these commands. I don't reboot often so it isn't a huge deal for me.

 

Also I am running the commands from a windows PC, but any ADB client can do it.

 

1. Download and install the Samsung USB Driver onto your Windows PC.

2. Download and install the Windows ADB (Android Device Bridge) software from Google (just need to unzip it, no actual install procedure).

3. On your Samsung phone, go into Settings and check "Enable USB Debugging"

4. Connect your Samsung phone to the Windows PC and it should pop up on the phone and ask to allow USB debugging, you want to allow it.

5. Open a windows command prompt, navigate to the folder where adb.exe exists (where you unzipped it). Run the following commands (two separate commands):

 

adb devices <-- should show one entry under "list of devices attached". If it says "unauthorized" then you need to make sure and allow USB debugging. You may need to go on the phone under settings and "Revoke USB debugging authorizations" and re-allow it.

 

adb shell dumpsys deviceidle disable <-- this will disable light and deep idle

 

6. That's it, unplug the phone from the PC and you're good to go. At least until you reboot.

Highlighted

I have exactly the same problem on my brand new Galaxy Note10+ as described by many others in this thread. When the phone has been on standby (screen off) for 5-10 minutes or longer, it receives no notifications from Gmail. Sometimes, when turning on the screen, notifications (sound and popup) appear instantly, sometimes not - and I have to actually open the Gmail app to see if there are any new messages. The stock Samsung e-mail app does NOT solve this issue (interesting that it wasn't pre-installed, only the Gmail app, so I had to download it from Google Play Store). I tried disabling the Gmail app and setup the Samsung app instead, but it turned out to behave in the exact same way.

Someone mentioned that Gmail was "woken up" by another app, and I have the same experience. Strangely, I receive all notifications from Google Calendar and other Google services, and yesterday I noticed that at the very same time I received a Calendar notification, the Gmail notification was suddenly activated (telling me about an e-mail received two hours earlier!). This issue is driving me mad, especially after having spent $1,300 on a state-of-the art smartphone. Samsung here in Denmark are currently investigating this, but I must admit that I have little hope of any solution based on the hundreds and hundreds of similiar complaints from users around the world 😞

 

And yes, every single battery optimization, background data restriction anti-sleep-keep-alive setting has been disabled.


SAMSUNG, this is not OK!

Highlighted

Same issue on my new Note 10+. IF I can't find a fix that is long-term then I may return the phone. Had this issue on my s8 and hoped when I upgraded it'd be fixed. 

Same issue with my new samsung a50 , android 9 - when i am using phone , i am getting all notifications, but when i am not using it for more then 5-10 mins , i will not get any notifications alerts , until i tap a screen , then all emails and notifications suddenly comes together. 

Highlighted
Just disable optimizing battery usage and issue is solved. Might take a restart and a night to fully take effect, but I haven't had the issue since.
Highlighted
my phone is on the side for a while unused and i send a test email to my phone the 'email' does come first and somehow wakes up the gmail app and then the email arrives also in the gmail app.
Top Liked Authors