Support

Open search

Delayed notifications issue affecting all range of Samsung devices since at least half a year.

Highlighted
First Poster

Hello,

 

Introduction:

 

Currently ALL newer flagship models are affected by delayed notification issue for at least past 6+ months,  which started happening after around may 2018. Most devices are affected such as: S7, S8, S9, Note 9 and similar.

This is related to "doze" feature of android phone, where samsung optimization whitelist options are not working correctly thus affecting almost all samsung phones.

 

The issue  is reproduced during following scenario:

 

1. User locks phone, waits around 5m

2. App sends notification (which is not marked as PRIORITY in google push services).

3. User does not get notification

4. User unlocks phone, and suddenly multiple "delayed" notifications arrive.

 

Multiple users has reported the issue and tried various workarounds such as:

 

- Disabling battery optimization for certain apps

- Disabling all battery optimization options

- Making sure "WIFI" connection is always maintaned, even during sleep mode

- Making sure DATA connection is always maintaned

- Restoring device to factory

- Totally replacing devices with new ones.

- Wiping cache and similar

 

There is currently only one temporarly solution working, which is disabling doze using adb console. This workaround is temporarly and works until next reboot. It requires setting phone to debug mode and connecting to it.

 

"adb shell dumpsys deviceidle disable"

 

Samsung reaction:

 

Samsung is totally ignoring the technical issue since at least 6 months or more. There are multiple threads all over the web about such problem existing. Examples:

 

1. https://us.community.samsung.com/t5/Galaxy-S8-Questions-and-Answers/Delayed-notifications/td-p/11494...

2. https://forums.androidcentral.com/samsung-galaxy-note-9/911157-push-notification-delay-when-screen-o...

3. https://forums.androidcentral.com/samsung-galaxy-s8-and-s8-plus/886249-help-delayed-notifications.ht...

4. https://forums.androidcentral.com/android-pie/904647-notifications-delayed-stopped-5.html

5. https://forums.androidcentral.com/samsung-galaxy-s9-s9-plus/891659-s9-plus-delayed-notifications-can...

6. https://forums.androidcentral.com/samsung-galaxy-note-9/906887-delays-notifications.html

 

Implications:

 

The issue is making phone totally unusuable for people who rely on instant notifications, such as alerts related to financial services like declining stock rates and similar. I dont understand why such critical thing like delivering notifications in time is totally ignored by samsung. The issue is not present on any other android phones.

 

Request:

 

If you have ability to contact someone of samsung development team, please forward this thread to make sure there will be finally reaction. Please reply to this thread if you have same issue.

336 REPLIES 336
Highlighted

After a few days of looking into it, I've feel like Google doesn't consider this a bug but a feature. Everything I've read has made it seem like they are trying to de-prioritize certain applications for instant notificiations as a way to improve battery life.

 

The fix in the OP to disable doze does reduce the notificition delay to anywhere from 5 seconds to 1 minute after my older phone, but it seems like there's another issue here at play.

 

There's an app called PNF (Push Notifications Fixer) that says:

"Every x minutes the app invokes an android activity that will send an heartbeat network packet on the push connection. Sending an heartbeat every 5 minutes should be enough to always keep the connection alive and all your push notifications will be instantly." It avoids the tcp connection timeout that can occurs on some wifi routers or on some mobile carriers.

 

So this may explain why it's been such a persistant bug for so long, the fault here actually lies with how Google is interacting with the wifi/mobile connection. In other words, this isn't a problem specific to the Galaxy series or even Samsung. I've seen reports of this happening on Pixel and OnePlus phones too. Rather, this is a Android OS issue.

 

I've read Huawei has gone into their phones and done specific changes (to what extent I don't know) that target and fix the Doze issue, but no one has really figured out the heartbeat issue.

 

In conclusion, the only option right now is to:

- Disable Doze using the ADB command in OP (repeat whenever your reboot/phone dies)

 

I've also gone into my Google account sync settings and manually synced everything, that seemed to help a bit too ( see Edit at the end) I didn't touch Bixby at all setting the phone up, turn off everything related to battery and power saving.

 

It's a bummer because if this doesn't work for you, and you need your notifications right away, you may need to consider a iOS phone. However, they are incredibly locked down and don't include a headphone jack. It seems like phones are becoming dumber and dumber, best of luck to anyone who finds this thread.

 

Edit: https://old.reddit.com/r/Android/comments/6t24ao/potential_gmail_syncpush_notification_delay_fix/

Highlighted
New Member

I found a fix. Go into developer options and turn on Mobile data always active. That worked for my phone.

Highlighted

Can't see that option on the s9+

Highlighted

Thanks user 7

Highlighted

Thanks User7 - this seems to work for me as well.

Highlighted

@Galaxy-S9 wrote:

Thanks User7 - this seems to work for me as well.


Where do i find this option on the s9+ please

Highlighted

You'll find this setting in developer mode options. To enable the developer mode menu, open Settings, select About phone, then choose Software Information. Scroll down the screen and tap Build number several times until you see a message that says “Developer mode has been enabled”.  You should now see the Developer Mode menu in your Settings.

Highlighted

@Galaxy-S9 wrote:

You'll find this setting in developer mode options. To enable the developer mode menu, open Settings, select About phone, then choose Software Information. Scroll down the screen and tap Build number several times until you see a message that says “Developer mode has been enabled”.  You should now see the Developer Mode menu in your Settings.


Thank you

Highlighted

This will affect battery life 

Highlighted

Agreed.  Only use this option if you need to receive notification of emails immediately.

Top Liked Authors