Support

Open search

Delayed notifications issue affecting all range of Samsung devices since at least half a year.

Highlighted
First Poster

Hello,

 

Introduction:

 

Currently ALL newer flagship models are affected by delayed notification issue for at least past 6+ months,  which started happening after around may 2018. Most devices are affected such as: S7, S8, S9, Note 9 and similar.

This is related to "doze" feature of android phone, where samsung optimization whitelist options are not working correctly thus affecting almost all samsung phones.

 

The issue  is reproduced during following scenario:

 

1. User locks phone, waits around 5m

2. App sends notification (which is not marked as PRIORITY in google push services).

3. User does not get notification

4. User unlocks phone, and suddenly multiple "delayed" notifications arrive.

 

Multiple users has reported the issue and tried various workarounds such as:

 

- Disabling battery optimization for certain apps

- Disabling all battery optimization options

- Making sure "WIFI" connection is always maintaned, even during sleep mode

- Making sure DATA connection is always maintaned

- Restoring device to factory

- Totally replacing devices with new ones.

- Wiping cache and similar

 

There is currently only one temporarly solution working, which is disabling doze using adb console. This workaround is temporarly and works until next reboot. It requires setting phone to debug mode and connecting to it.

 

"adb shell dumpsys deviceidle disable"

 

Samsung reaction:

 

Samsung is totally ignoring the technical issue since at least 6 months or more. There are multiple threads all over the web about such problem existing. Examples:

 

1. https://us.community.samsung.com/t5/Galaxy-S8-Questions-and-Answers/Delayed-notifications/td-p/11494...

2. https://forums.androidcentral.com/samsung-galaxy-note-9/911157-push-notification-delay-when-screen-o...

3. https://forums.androidcentral.com/samsung-galaxy-s8-and-s8-plus/886249-help-delayed-notifications.ht...

4. https://forums.androidcentral.com/android-pie/904647-notifications-delayed-stopped-5.html

5. https://forums.androidcentral.com/samsung-galaxy-s9-s9-plus/891659-s9-plus-delayed-notifications-can...

6. https://forums.androidcentral.com/samsung-galaxy-note-9/906887-delays-notifications.html

 

Implications:

 

The issue is making phone totally unusuable for people who rely on instant notifications, such as alerts related to financial services like declining stock rates and similar. I dont understand why such critical thing like delivering notifications in time is totally ignored by samsung. The issue is not present on any other android phones.

 

Request:

 

If you have ability to contact someone of samsung development team, please forward this thread to make sure there will be finally reaction. Please reply to this thread if you have same issue.

344 REPLIES 344
Highlighted
You are right about BLE but before BLE existed there simply wasn't a low energy option. Right now, Wifi Direct might be power intensive but it won't stay that way forever. One day, there could be a Wifi Direct Low Energy and I wish Microsoft or some other big money company would pursue this.
Highlighted

@jraymond217 wrote:

That's a very reasonable question because it would have been easy to miss or dismiss something like that in 30 pages of comments.  Unfortunately, I DID try WakeLock 3 and it still didn't do the trick.  I was convinced too because it specifically says they solved the issue for Android.  Well, they say Galaxy and not S9, so maybe there's a significant difference in the way those devices operate.  Even with it running and all turned on, I would still get delays of up to 15 minutes.  Something happens every 15 minutes that makes it check, and then texts would come in.  Someone will figure it out someday.  As the cast of Glee once sang, don't stop believin'.  For now, it's good until I reboot, which I used to do with a nightly shutdown but now just put into airplane mode.  The only reason I prefer to shutdown is because every second that a computer is on is time that something can go catastrophically wrong with it.


If it's 15 Min and on WiFi, try push notification fixer and set to 5 Min. See if that helps. 

Highlighted
I might have tried one of those before, but I'm willing to try again. It's sure not going to break it worse. I do think that my issues still happen even when WiFi is turned off though. Thanks for the advice, @aarick. I'll report back if anything good comes of it.
Highlighted

😞  Confirmed Push Notification didn't help.  Still a 10 minute delay.  Silly phone.

Highlighted

No luck so far identifiying which bt device is causing issues. Definitely all is working good when BT is off completely. The moment I turn it on while I am at home, delays kick in straight away.

Highlighted
  • What sort of Bluetooth devices do you have connected? 
  • Any behavior difference if you're on WiFi/WAN?
  • What if you leave Bluetooth on, but unpair all devices (this might be a pain, but could at least point to the issue being a connected/paired device rather than a lower level Bluetooth driver issue).
Highlighted

@phant0m wrote:
  • What sort of Bluetooth devices do you have connected? 
  • Any behavior difference if you're on WiFi/WAN?
  • What if you leave Bluetooth on, but unpair all devices (this might be a pain, but could at least point to the issue being a connected/paired device rather than a lower level Bluetooth driver issue).

Bluetooth devices:

  • 8 earbuds/headphones 
  • 2 speakers
  • 3 smartwatchs (2 gear wearable, 1 wear os)
  • Car head unit (Full Android - PX5, not android auto)
  • Tune2Air car bluetooth

I also have smart locks and Upright Go (posture correcting device), but those connect from the app and doesn't show up in the bluetooth device lists. I don't think it's my smart watches as I used them outside the house through the day and the lag doesn't return until i get home.

Yes, I am working through testing all the different scenarios. So far have tested the following while at home:

  • bt off, wifi on and off (on lte)
    • no lags
  • on wifi and off wifi (lte) with bt on
    • No difference, always have lag
  • turn off all my smartwatches
    • no difference, always have lag with bt on
  • removed all bt devices except for my smartwatches
    • I think this might have fixed it maybe? But I ran out of time this morning while testing but it didn't seem like it was showing any lag. I tested a lot of different scenario with this one. Will test this extensively again tonight after work. I did test with the Plantronics Savi-700 still plugged into power, but unpaired. I think it was still causing lag. Before I left for work I unplugged the savi-700 headset from power to stop it broadcasting bluetooth. I also removed all the remaining bt devices (all would have been turned off anyway) and that seems to have fixed it.
    • if this does not fix the issue, then i might have to unpair my smartwatches too, which is a pain as I have to reset everything to repair it back. Also turn off the smart locks.
    • If this fix the issue, then I will slowly pair devices back one at a time to see if I can pinpoint which device it might be (have a feeling it might be Plantronics Savi-700 headset) 
Highlighted

Interesting.  So, it seems like the issue is definitely related to bluetooth, since it's only happening when BT is enabled (which I think is what most of us were assuming).  Can you share your phone information - device hardware & software?  Curious if there's any correlation...

 

For reference:  My issue was with a Galaxy S10+ (G975U) on Android 10 (and issue solved by removing my Win10 PC from paired BT devices - was using Dynamic Lock)

Highlighted

My Bluetooth is now disabled on the Galaxy S9+ since 2 days (as a trial) and I definitely still have the motification delay issue.
Notifications for the very same Google Calendar events on the very same Google account arrive exactly on time on an old Nexus 7 (maximum 1 second delay) but are delayed minutes on the Galaxy S9+ even with BT disabled. Both devices are on the very same Wi-Fi.  BT does not appear to be at the origin of the notification delay problem I have.  Continuing to search...

Highlighted

@phant0m wrote:

Interesting.  So, it seems like the issue is definitely related to bluetooth, since it's only happening when BT is enabled (which I think is what most of us were assuming).  Can you share your phone information - device hardware & software?  Curious if there's any correlation...

 

For reference:  My issue was with a Galaxy S10+ (G975U) on Android 10 (and issue solved by removing my Win10 PC from paired BT devices - was using Dynamic Lock)


I am on a Galaxy Note 10+ (SM-N975F) Exynos running Android 9, One ui 1.5, 1 November 2010 security update.

 

So you're on Android 10 and still have the issue. That sucks that they haven't fixed it for Android 10.

 

Quick update, yeelock is causing issues. It's not in my list of bt devices only from the yeelock app but the moment I use my phone to unlock, the delays return.

 

I know it's not the only device that is causing issues as previously the moment I come home it will start the delay so I know there is another bt device at home causing issues. Still testing. 

Top Liked Authors