!-- End Google Optimize -->

Open search

Can't switch from Wifi to Mobile data automatically


(Samsung S9+)When i'm connected on Wifi everything works fine,but when i get out of range it switches to mobile data but no internet is available.I see that there is no ip address also.I have to swith to airplane mode on then off ,then the phone will conect on mobile data.Anyone else has or had this issue?It's annoying,i'm planning to return this phon if this issue is unsolvable.


I have the same problem with my Samsung Galaxy A8 Dual SIM 2018 (SM-A530F). Used in the Netherlands with local carriers.


I bought the phone a week ago and it came with Android Oreo patched with the july 2018 patch out of the box. I had this problem since the unboxing.

Gonna try your fix and see if it helps.

For me the settings are not under  the dialpad settings. For me they are under:

Setttings --> Connections --> Mobile Networks --> VoLTE calls <sim card name> 

I have disabled the option from there. Hope this helps other users.


Okay, just a quick update...


So for my Samsung A8 2018, the fix with disabling did not work.


I did find that the APN settings were incorrect...once I corrected them withe the settings the provider specified and a quick restart after that to apply the new settings everything worked correctly again :smiling-face:





Anyone still got this issue?


I still am having this problem. I have tried everything besides a factory reset. This started happening right after the update this morning. APN settings are greyed out and cannot edit them. 


I have the same problem, 

Every time I leave home my phone can not switch to LTE and I'm missing lots 9f calls and messages. 

Very annoying 

Did you solve this problem ?


I fixed this issue by setting the authentication method to "none" on the APN settings...


After this it appears to fix the problem when switching from 5 GHz WiFi to LTE...


The issue still exists when switching from 2.4 GHz WiFi to LTE...


I found that additional APNs were added after rebooting my phone... On those the authentication method was set to PAP authentication....


I deleted those newly made APNs again.. Hope that'll work... If not then I'm trying to change the authentication method on the new APNs to "none"...


I'll keep you posted on how that affects the problem and whether or not it solves it....


We have Samsung users in Singapore that experience this has there been an update or is this a Cellular provider issue?


Thank you


I am having same problem.  Not using T mobile.  In USA.  I  just turn WiFi off and it seems to connect.  Bit of a bother if you forget to turn it back on.


I have the same problem and I've had the phone replaced twice so i'm working on my third phone which does the same thing. Also, when I go indoors to an office which may have a secure locked wifi my 4g disappears and have to turn airplane mode on and off and the 4g comes back strong. So why does it disconnect in the first place... Have been through all with Samsung and At&t and it still does it. Wish I'd never upgraded to this phone as my S5 worked fine. Thinking of going to an Iphone if I can't get this rectified.


I have this same problem with a dual sim S9+

Top Liked Authors