Support

Open search

Bluetooth doesn't work after PIE

Highlighted
Explorer

Hi community! Bluetooth in my Samsung s9 after installing PIE doesn't work yet in my car for audio or calls

The device is connecting and disconnecting from car every minute 

Before installing new software it worked very well with never problem 

I tried to clear cache  re pairing device but same problem!

It's impossible to listen any song and it is the same with other app as YouTube or similar 

The devices stay connected for a minute and after they disconnect, after 10 seconds they automatic re connect

The car is range rover from 2018 not an old car

please help me !! 

96 REPLIES 96
Highlighted

So I've tried every recommendation so far and no luck. The new Disco Sport will connect and disconnect continuously and is now driving me crazy.

 

Taking it in to Land Rover service on Tuesday so hoping to get some idea on when a fix is due, and perhaps updating to Android Auto.... I'm not confident though.

 

Highlighted

Land Rover can't fix it at the moment, so they tell me.  Try putting the blue tooth setting, Dual audio 'on' which should turn off the media volume sync option off automatically.  Do this in conjunction with the previous advice.  Doesnt work perfectly but has helped alot. 

Highlighted
First Poster

Same problem with 2017 landrover discovery and note 9, brand new phone last month connected fine for about 3 says then did automatic update and not connected properly since.

Highlighted

Solved for me!

2016 Discovery Sport

Samsung S10, Android 9, Kernel 4.14.85-15820661 (Apr 16 update), security patch level April 2019.

 

I did the following:

1. Bluetooth advanced settings, dual audio on (volume and ringtone sync off).

2. Developer settings, changed PBAP version to 1.1 and turned multiple PBAP properties off.

3. Unpair car from phone, and remove phone from car. 

4. Initiate a new pairing with the phone, and when asked I allowed only contact sync, not messages sync.

 

No problems since, both phone and music connected. I do not know exactly which of those changes made it work, or combination thereof. I don't dare lab with that haha! Hope that helps! 

Highlighted

Cool.

For me and my S10+ this setting solved the bluetooth connecting problem with my Land Rover Discovery Sport 2018 as well! Thank you very much @ .

(I tried all suggested solution and not one was working. Your solution is the only one which is stable for me. Tested over whole weekend and the BT connection ist now stable within my Land Rover Discovery Sport 2018 and Samsung S10+ with Android 9.0 Pie)

 

 

Highlighted
Wonderful! Glad to hear that. I've heard that some doesn't have the PBAP setting in dev options (not sure if it's because of software version from Android or phone vendor), and they didn't get this to work, so PBAP definitely seems to be an issue for the JLR cars.
Highlighted
For me is not working on S8+ and I have BT PBAP option ( I set to vers 1.1) I try on both cars, (Audi and MB) same issue, bt connection is broken randomly.
Highlighted
Hmm, maybe then, this may be a Jaguar/Land Rover specific solution? S8 I've used with my LR never had an issue, so your incompatibility issue might be different... Just speculating, but it's likely.
Highlighted

@ have you set the other values as well?
Not only PBAP needs to be set, the other params as well.

 

Just to document for others. Maybe this fix is really just for S10/S10+ owners.

Highlighted

This worked for my S9 with the Discovery Sport, with a few tweaks so thanks!   I didn't have an option in s9 settings to choose the PBAP version, but there was an option to change the codec type right above the other option.  My fix  was to pick BT LDAP codec one version previous (13) of current selection, and turned off all automatic selection options and picked the middle ones.  (Speed, quality, etc.)

Top Liked Authors