Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Have the WiFi issue been acknowledged by Samsung yet

(Topic created on: 14-03-2023 07:31 AM)
1281 Views
b0redj0rd
Explorer
Options
I'm wondering if the connectivity issues with WiFi 6 have been acknowledged by Samsung yet or not? 

If so, have they stated a fix is on the way? 

If not, I'm going to trade this phone. I can't live with these issues indefinitely. 
0 Likes

1 Solution


Accepted Solutions
Solution
AntS
Moderator
Moderator
Options

Hi @b0redj0rd ,

 

Appreciate it got buried somewhat in the main thread we have on the issue but I can confirm that Dillz2003’s reply from our Support agent is the latest we have on it: https://eu.community.samsung.com/t5/galaxy-s23-series/s23-ultra-connect-to-wifi-but-no-internet-cons...

 

I’ll re-post the relevant bit here:

 

We're aware of this Wi-Fi connection problem on specific Wi-Fi AP with Galaxy S23 Ultra device. This is caused by a compatibility issue (confirmed occurring on some TPLink AP products). This symptom may appear in various ways such as no internet connection, slow speed or data disconnection. You can resolve the problem with a temporary workaround, and there will be a software release containing a fix. For now, head into Settings > Connections > Wi-Fi > Tap settings on the connected Wi-Fi AP > Tap ‘Manage router’ > Log in with password on router setting page > ‘Wireless’ menu > Mode > Select ‘802.11a/n/ac mixed’ on the Mode menu > Check if it is selected with right one > Save the setting > Check after reconnecting the Wi-Fi AP. We'd also advise you to check for updates regularly: Settings > Software update > Download and install

 

We don't have any info on when that fix will be released.

View solution in context

13 REPLIES 13
theroninhunter
Pathfinder
Options
What wifi issues? I'm on WiFi 6e without any faults
0 Likes
leicesterMan
Troubleshooter
Options
I'm on wifi 6 with s20 ultra . 1.6gbps
0 Likes
Solution
AntS
Moderator
Moderator
Options

Hi @b0redj0rd ,

 

Appreciate it got buried somewhat in the main thread we have on the issue but I can confirm that Dillz2003’s reply from our Support agent is the latest we have on it: https://eu.community.samsung.com/t5/galaxy-s23-series/s23-ultra-connect-to-wifi-but-no-internet-cons...

 

I’ll re-post the relevant bit here:

 

We're aware of this Wi-Fi connection problem on specific Wi-Fi AP with Galaxy S23 Ultra device. This is caused by a compatibility issue (confirmed occurring on some TPLink AP products). This symptom may appear in various ways such as no internet connection, slow speed or data disconnection. You can resolve the problem with a temporary workaround, and there will be a software release containing a fix. For now, head into Settings > Connections > Wi-Fi > Tap settings on the connected Wi-Fi AP > Tap ‘Manage router’ > Log in with password on router setting page > ‘Wireless’ menu > Mode > Select ‘802.11a/n/ac mixed’ on the Mode menu > Check if it is selected with right one > Save the setting > Check after reconnecting the Wi-Fi AP. We'd also advise you to check for updates regularly: Settings > Software update > Download and install

 

We don't have any info on when that fix will be released.

b0redj0rd
Explorer
Options
Thank you very much Ant, I really appreciate that response!
BN44
Pathfinder
Options

I have read articles from a couple of tech websites that say Samsung has acknowledged it and there was an update already that fixed it for some people, with the full fix on the way. I know that's pretty well what AntS posted already, but just wanted to say that Samsung has also spoken about it officially through the media.

So let's hope it doesn't take too long 😊

Bratnesti
Explorer
Options
I assume it's an issue that doesn't affect every user. My WiFi6 has been running flawlessly up to yet, I've also had it connected to my Tp-link boosters, and still works great then.
0 Likes
b0redj0rd
Explorer
Options
I'm not on TP hardware, I'm running a netgear nighthawk rax200 with a mesh extender (eax80, also netgear) and I get issues moving around the house all the time.
0 Likes
NeedItFixed
Explorer
Options
Getting cellular issues after trying everything
53fireman
Apprentice
Options

This is not just a Wi-Fi 6, ultra, or TP-Link specific issue. I have the same problem on my regular S23 on an older Verizon router, that's not Wi-Fi 6. It is most annoying.

0 Likes