Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Boost select device button not working

(Topic created on: 31-07-2023 10:06 AM)
1847 Views
patch13
Explorer
Options
I brought my S23 just over a week ago and since then I have been trying to claim the free 6 months Disney, I have not ever had a subscription to Disney I press redeem then it takes me to the select device button ut nothing happens,I've tried on the boost app and over the Internet link but the same happens I've cleared my cache and spoke to online support but I'm still no further on, has anyone else had this problem and bin able to fix it please
41 REPLIES 41
AaronAJ
Moderator
Moderator
Options

@patch13 I am sorry to hear this. What did our colleagues advise you? Are you trying to claim for the free 6 months of Disney+ via the Chrome browser?


0 Likes
patch13
Explorer
Options
Yes I am, I've tried on Chrome and on the boost app they said to clear my cache, try going incognito,try the boost app, try using a different server but I have done all this and it still doesn't work I can't get past the select device part I also have tried log in with my email and logging in with my device to claim it.
0 Likes
AaronAJ
Moderator
Moderator
Options

@patch13 What was the last thing they have advised you? Please drop me a message and I can take some details to look into this.


0 Likes
patch13
Explorer
Options
They asked me to use chrome which I did go incognito, clear my cache, use a different browser, use the boost app which I've done all of the above.
0 Likes
AaronAJ
Moderator
Moderator
Options

@patch13 Please drop me a message, and I'll be happy to discuss this with you.


0 Likes
Rajp14
Explorer
Options
Did you manage to fix? Been having the same issue
0 Likes
patch13
Explorer
Options
No still no fix as of yet, I'm glad it's not just me.
0 Likes
Rajp14
Explorer
Options
Gosh, I've been just going round in a loop, driving me mad
patch13
Explorer
Options
Yes me too, I have tried everything I can think of there has got be a answer somewhere if other people are having the same problem.
0 Likes