Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

S22 ultra Does not connect to 5g

(Topic created on: 14-04-2022 12:43 PM)
16996 Views
Rutton
First Poster
Options

Hi all, hope you can help....

I bought a s22ultra in Feb while in India and was assured that the 5g would also work in Europe. I live in the Netherlands... however once i got back, it refuses to connect to the KPN 5g network.... 

A quick look at the spec suggests it should not be a problem... any ideas or suggestions?

0 Likes
14 REPLIES 14
AndrewL
Moderator
Moderator
Options

@Rutton: If the phone was intended for use outside your current region, then you may experience some compatibility issues with 5G network bands. Do you have a 5G SIM, and have you reached out to your network to ensure that you have 5G coverage in your area? If you head to Settings > Connections > Mobile Network > Network Mode, is is set to 5G/4G/3G/2G (auto connect) for the relevant SIM? 

GoanGeek
Samsung Members Star ★
Options
As stated you need to request a 5g sim from your provider and have 5g in your area.
Good luck.
"WI-FI went down for five minutes, so I had to talk to my family.
They seem like nice people"
Rutton
First Poster
Options

Hi Andrew,  thanks for your response. Yes I have a 5g Sim with coverage in the area. When I stick the Sim in another phone I do get 5g.. yes I also have the phone set for 5g...

0 Likes
Rutton
First Poster
Options

Thanks for your reply.... yes the Sim is 5g

0 Likes
GoanGeek
Samsung Members Star ★
Options
Try a simple phone restart and see if it helps.

Ask your provider if they can send you the apn settings again or if you could manually add them.
"WI-FI went down for five minutes, so I had to talk to my family.
They seem like nice people"
0 Likes
Rutton
First Poster
Options

Hi goan geek, I have also done a complete reset, with no success

0 Likes
Ventor
Samsung Members Star ★★
Options

@Rutton Hello, some Galaxy S 22 Ultra experience this problem and for the moment a correction has not been made. Temporarily I could try to place SIM 1 to SIM 2 slot, to see if it works. Greetings.






"The quieter you become-the more you are able to hear..."


0 Likes
Rutton
First Poster
Options

Hi vendor,

Thanks for the suggestion.  Worth a try, however, sadly this did not work either..

0 Likes
Jer123cre8
Explorer
Options

thanks this worked for me though, I believe i have a south Korean model even though I live in the uk 

0 Likes