Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Recipient's getting echo on voice calls

(Topic created on: 07-10-2021 03:59 PM)
Hazer
First Poster
Options
Galaxy S21 Series
Sp I just recently upgraded to a new S21 from a Razer Phone 2 and been liking it so far.

Apart from on all voice calls the other person hears themselves all the time. I even tried on a second mobile and it's really bad.

After googling it seems its quite common, is there any fix for it? It can't be a carrier issue since its the same sim cars from previous phone and it happens on WhatsApp calls aswell
15 REPLIES 15
Ventor
Samsung Maker ★
Options
Galaxy S21 Series

@Hazer Hello, I would ask my telephone company for a copy of the SIM card.

0 Likes
AndrewL
Moderator
Moderator
Options
Galaxy S21 Series

@Hazer: If you place the call on loudspeaker, or use a headset, does the issue persist? Head over to your dial pad and type in *#0283#, then select “Start: RCV_1stMic” and speak into your phone like you’re on a call. Can you hear yourself talk, and is the echo present? 

0 Likes
Hazer
First Poster
Options
Galaxy S21 Series
Hi Andrew, so when I done the loudspeaker part the recipient no longer gears any echo.

And then when doing that last thing I could hear myself and yes there was an echo
0 Likes
AndrewL
Moderator
Moderator
Options
Galaxy S21 Series

@Hazer: Is the echo occurring for both incoming, and outgoing calls? Do you have a case or cover on the device? If so, try removing it temporarily to see if this helps. Also, make sure you're on the latest software by heading to Settings > Software > Download and Install. If the problem persists, try restarting the phone in Safe Mode, and make a call. This will disable all third party apps, and help to determine if the problem is stemming from an external source. To proceed, press and hold the Power button until the 'Power off' prompt appears on the screen then release > Touch and hold Power off until the 'Safe mode' prompt appears then release > To confirm, tap Safe mode. If the echo is no longer present in Safe Mode, restart the phone as you would normally and uninstall any recently installed applications. 

0 Likes
Tami90
First Poster
Options
Galaxy S21 Series
I've also been having this problem since the last update, none of these things fix it. Is there any other success?
Faultys20
First Poster
Options
Galaxy S21 Series

I've just started having this problem, I have to take all my calls with speakerphone on or they can't hear me the echo is that bad. I have installed nothing BUT the Samsung update...which I always end up regretting one way or another.

It seems to be on incoming calls only.

I'm using an s20.

For such an expensive bit of kit you'd think there'd be a fix for this by now but loads of people with the s20 = s21 phones are having it.

What's going on? 

Victor A
First Poster
Options
Galaxy S21 Series

Started having the same problem on my S21 around a weeks ago. When talking on WhatsApp sometimes recipients hear a strong echo, which come and goes. Usually the call starts fine, but if I'm not talking for 15-20 seconds, the echo problems starts. It can go away if I start talking again, but most of the times I have to switch to loudspeaker and back to get rid of the problem. 

Switching to headset will also help to stop echo. 

Never really checked if the same problem exists on the standard network call, but I rarely use it. 

I blame the Security update from November 1st, hasn't had any problems before that and that's the only changes to the phone happened in the last month.

@AndrewL tried that microphone loopback test, I can hear myself but no echo. 

Any suggestions? 

0 Likes
Ventor
Samsung Maker ★
Options
Galaxy S21 Series

@Hazer @Victor A ,Hi, two things you could try: Reset network settings and disable Wifi calls.

0 Likes
Victor A
First Poster
Options
Galaxy S21 Series

@Ventor disabling WiFi calls was the first think I've tried, although the problem was during the Whatsapp calls mostly.  Didn't help.

Tried to reset the network settings, made another call just now - nope, the problem is still here. 

Any other suggestion, please? 


0 Likes